dev-util/catalyst: Add iso useflag, to make keywording easier
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 5 May 2019 15:56:10 +0000 (17:56 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 5 May 2019 15:56:40 +0000 (17:56 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
dev-util/catalyst/catalyst-3.0.4.ebuild
dev-util/catalyst/catalyst-9999.ebuild
dev-util/catalyst/metadata.xml

index c891993d68a49e2195a2e2b76e68dcdcb426e7a4..8126cc048190ec40795a111135dd1a51ad58659f 100644 (file)
@@ -21,7 +21,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Catalyst"
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="ccache doc kernel_linux system-bootloader"
+IUSE="ccache doc +iso kernel_linux system-bootloader"
 
 DEPEND="
        app-text/asciidoc
@@ -35,10 +35,10 @@ RDEPEND="
        sys-fs/dosfstools
        !kernel_FreeBSD? ( || ( app-arch/tar[xattr] app-arch/libarchive[xattr] ) )
        kernel_FreeBSD? ( app-arch/libarchive[xattr] )
-       virtual/cdrtools
        amd64? ( >=sys-boot/syslinux-3.72 )
        x86? ( >=sys-boot/syslinux-3.72 )
        ccache? ( dev-util/ccache )
+       iso? ( virtual/cdrtools )
        kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
 "
 PDEPEND="system-bootloader? ( >=sys-apps/memtest86+-5.01-r4
index 85870e20421addb86c740673c0fb6c700587e97f..8126cc048190ec40795a111135dd1a51ad58659f 100644 (file)
@@ -12,7 +12,7 @@ else
        KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
 fi
 
-PYTHON_COMPAT=( python{3_5,3_6} )
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
 
 inherit distutils-r1 ${SRC_ECLASS}
 
@@ -21,7 +21,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Catalyst"
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="ccache doc kernel_linux system-bootloader"
+IUSE="ccache doc +iso kernel_linux system-bootloader"
 
 DEPEND="
        app-text/asciidoc
@@ -35,10 +35,10 @@ RDEPEND="
        sys-fs/dosfstools
        !kernel_FreeBSD? ( || ( app-arch/tar[xattr] app-arch/libarchive[xattr] ) )
        kernel_FreeBSD? ( app-arch/libarchive[xattr] )
-       virtual/cdrtools
        amd64? ( >=sys-boot/syslinux-3.72 )
        x86? ( >=sys-boot/syslinux-3.72 )
        ccache? ( dev-util/ccache )
+       iso? ( virtual/cdrtools )
        kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
 "
 PDEPEND="system-bootloader? ( >=sys-apps/memtest86+-5.01-r4
index 988e80de6cc2abc643637f9ed1f8c012c1065ac2..f89291ab2936cdf68400fa9d56b72eee78f169a5 100644 (file)
@@ -10,6 +10,7 @@
   </maintainer>
   <use>
     <flag name="ccache">Enables ccache support</flag>
+    <flag name="iso">Pulls in the depends for building iso images</flag>
     <flag name="system-bootloader">Pulls in the depends needed to setup livecd bootloader from the host system rather than using a cdtar</flag>
   </use>
 </pkgmetadata>