app-emulation/libpod: Remove old version 1.6.3-r2
authorZac Medico <zmedico@gentoo.org>
Sun, 19 Jan 2020 21:17:11 +0000 (13:17 -0800)
committerZac Medico <zmedico@gentoo.org>
Sun, 19 Jan 2020 21:17:35 +0000 (13:17 -0800)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Zac Medico <zmedico@gentoo.org>
app-emulation/libpod/Manifest
app-emulation/libpod/libpod-1.6.3-r2.ebuild [deleted file]

index f5d984e4cde8390287925347a8ddb168065e0508..b0d4744515587d5f2af15f3d5d46b44651e46df2 100644 (file)
@@ -1,4 +1,3 @@
 DIST containers-storage-1.14.0-vfs-user-xattrs.patch 14835 BLAKE2B 99c35933dcb25385ee83b80cf282c11c738d0e4d91216cc08a50522f6caa9bca5938299412908f16df404f99e80616a10b4c02c0ebc38240a987830ddaf15008 SHA512 62c7ed49728bd12b5706f59b0d4af3b18d90e8cfc2b06e681f84fe3f5d3e0cd5c0317147109c4e3ec4fec26f82c269af3c9813e47339ce102e4e97400b74627d
-DIST libpod-1.6.3.tar.gz 8340471 BLAKE2B b017a29ab034d8432b3abe2d920e0a71ad6542a5f088ed0de8fc67e846b409efbfd5be2e72908b52b5d21f05ce30c31db3bd55f8d8974711eb8f48cf8c3553a5 SHA512 a4d9f4c74db42fade86c36f4b2c27b8b3ff42db90af21bccab2eae8e9d710ae102c05e1fa926ac1d8e67613e11fa40163800077b61e49d90de521ab472e9c8dd
 DIST libpod-1.6.4.tar.gz 8340370 BLAKE2B f68f0e846a442aa0717d4918f24260560ee77c8abdecd5af3dec06ee95ab899d623b8797962ac416bf498f22643d45de5c6d86049eead9d5c93073957c3fd9bf SHA512 69322551ab196cd3859e03988178c59a47df6f00ef0768a56e40d785f6b2130df03ff0ea76d101e21e748ea9260ede144d31f3ec21922ffd70eb2969a77d4194
 DIST libpod-1.7.0.tar.gz 8679022 BLAKE2B 8a8037b75deae9f94461ab697b2a7cf095254c68d8436655c37a40375e3dd1a2b621672643e430acc8a656fcd516fa5a542e7104d6cfdbee3d213aca6228d410 SHA512 986ec7123127d3ffb26cecc39a2ae3d8a6dd3d147327449fc4e9d17f6e6606bde278f13920d0aef59410262801251e7b4cfe099cb5caafe9773533e8476848fe
diff --git a/app-emulation/libpod/libpod-1.6.3-r2.ebuild b/app-emulation/libpod/libpod-1.6.3-r2.ebuild
deleted file mode 100644 (file)
index 345beca..0000000
+++ /dev/null
@@ -1,142 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGIT_COMMIT="9d087f6a766259ba53b224944f1b7b778035c370"
-
-inherit bash-completion-r1 flag-o-matic go-module
-
-DESCRIPTION="Library and podman tool for running OCI-based containers in Pods"
-HOMEPAGE="https://github.com/containers/libpod/"
-CONTAINERS_STORAGE_PATCH="containers-storage-1.14.0-vfs-user-xattrs.patch"
-SRC_URI="https://github.com/containers/libpod/archive/v${PV}.tar.gz -> ${P}.tar.gz
-       https://github.com/containers/storage/pull/466.patch -> ${CONTAINERS_STORAGE_PATCH}"
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-SLOT="0"
-
-KEYWORDS="~amd64"
-IUSE="apparmor btrfs ostree +rootless selinux"
-REQUIRED_USE="!ostree"
-RESTRICT="test"
-
-COMMON_DEPEND="
-       app-crypt/gpgme:=
-       >=app-emulation/conmon-2.0.0
-       || ( >=app-emulation/runc-1.0.0_rc6 app-emulation/crun )
-       dev-libs/libassuan:=
-       dev-libs/libgpg-error:=
-       sys-fs/lvm2
-       sys-libs/libseccomp:=
-
-       apparmor? ( sys-libs/libapparmor )
-       btrfs? ( sys-fs/btrfs-progs )
-       rootless? ( app-emulation/slirp4netns )
-       selinux? ( sys-libs/libselinux:= )
-"
-DEPEND="
-       ${COMMON_DEPEND}
-       dev-go/go-md2man"
-RDEPEND="${COMMON_DEPEND}"
-
-src_prepare() {
-       default
-       sed -e 's| \([ab]\)/| \1/vendor/github.com/containers/storage/|' < \
-               "${DISTDIR}/${CONTAINERS_STORAGE_PATCH}" > \
-               "${WORKDIR}/${CONTAINERS_STORAGE_PATCH}" || die
-       eapply "${WORKDIR}/${CONTAINERS_STORAGE_PATCH}"
-
-       # Disable installation of python modules here, since those are
-       # installed by separate ebuilds.
-       sed -e '/^GIT_.*/d' \
-               -e 's/$(GO) build/$(GO) build -v -work -x/' \
-               -e 's/^\(install:.*\) install\.python$/\1/' \
-               -i Makefile || die
-
-       sed -e 's|OUTPUT="${CIRRUS_TAG:.*|OUTPUT='v${PV}'|' \
-               -i hack/get_release_info.sh || die
-}
-
-src_compile() {
-       # Filter unsupported linker flags
-       filter-flags '-Wl,*'
-
-       [[ -f hack/apparmor_tag.sh ]] || die
-       if use apparmor; then
-               echo -e "#!/bin/sh\necho apparmor" > hack/apparmor_tag.sh || die
-       else
-               echo -e "#!/bin/sh\ntrue" > hack/apparmor_tag.sh || die
-       fi
-
-       [[ -f hack/btrfs_installed_tag.sh ]] || die
-       if use btrfs; then
-               echo -e "#!/bin/sh\ntrue" > hack/btrfs_installed_tag.sh || die
-       else
-               echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
-                       hack/btrfs_installed_tag.sh || die
-       fi
-
-       [[ -f hack/selinux_tag.sh ]] || die
-       if use selinux; then
-               echo -e "#!/bin/sh\necho selinux" > hack/selinux_tag.sh || die
-       else
-               echo -e "#!/bin/sh\ntrue" > hack/selinux_tag.sh || die
-       fi
-
-       export -n GOCACHE GOPATH XDG_CACHE_HOME
-       GOBIN="${S}/bin" \
-               emake all \
-                       GIT_BRANCH=master \
-                       GIT_BRANCH_CLEAN=master \
-                       COMMIT_NO="${EGIT_COMMIT}" \
-                       GIT_COMMIT="${EGIT_COMMIT}"
-}
-
-src_install() {
-       emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
-
-       insinto /etc/containers
-       newins test/registries.conf registries.conf.example
-       newins test/policy.json policy.json.example
-
-       insinto /usr/share/containers
-       doins seccomp.json
-
-       newinitd "${FILESDIR}"/podman.initd podman
-
-       insinto /etc/logrotate.d
-       newins "${FILESDIR}/podman.logrotated" podman
-
-       dobashcomp completions/bash/*
-
-       keepdir /var/lib/containers
-}
-
-pkg_preinst() {
-       LIBPOD_ROOTLESS_UPGRADE=false
-       if use rootless; then
-               has_version 'app-emulation/libpod[rootless]' || LIBPOD_ROOTLESS_UPGRADE=true
-       fi
-}
-
-pkg_postinst() {
-       local want_newline=false
-       if [[ ! ( -e ${EROOT%/*}/etc/containers/policy.json && -e ${EROOT%/*}/etc/containers/registries.conf ) ]]; then
-               elog "You need to create the following config files:"
-               elog "/etc/containers/registries.conf"
-               elog "/etc/containers/policy.json"
-               elog "To copy over default examples, use:"
-               elog "cp /etc/containers/registries.conf{.example,}"
-               elog "cp /etc/containers/policy.json{.example,}"
-               want_newline=true
-       fi
-       if [[ ${LIBPOD_ROOTLESS_UPGRADE} == true ]] ; then
-               ${want_newline} && elog ""
-               elog "For rootless operation, you need to configure subuid/subgid"
-               elog "for user running podman. In case subuid/subgid has only been"
-               elog "configured for root, run:"
-               elog "usermod --add-subuids 1065536-1131071 <user>"
-               elog "usermod --add-subgids 1065536-1131071 <user>"
-               want_newline=true
-       fi
-}