dev-ruby/puppet_forge: fix gemspec to match deps in ebuild
authorHans de Graaff <graaff@gentoo.org>
Sat, 9 Feb 2019 10:55:33 +0000 (11:55 +0100)
committerHans de Graaff <graaff@gentoo.org>
Sun, 10 Feb 2019 07:25:15 +0000 (08:25 +0100)
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-ruby/puppet_forge/puppet_forge-2.2.9.ebuild

index 7223fbcbc0f0bfaf30893158d46904173f865d56..e343cdbdd5dc9a7690db3a3b1f3bc44c4a6c7d72 100644 (file)
@@ -9,6 +9,8 @@ RUBY_FAKEGEM_RECIPE_DOC="rdoc"
 
 RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
 
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
 inherit ruby-fakegem
 
 DESCRIPTION="Tools to access Forge API information on Modules, Users, and Releases"
@@ -30,4 +32,10 @@ ruby_add_rdepend "
 all_ruby_prepare() {
        # Avoid integration and user specs since they all require network access
        rm -rf spec/integration spec/unit/forge/v3/user_spec.rb || die
+
+       # Fix overly restrictive dependencies
+       sed -i \
+               -e '/faraday/ s/0.14.0/0.99.0/' \
+               -e '/faraday_middleware/ s/0.13.0/0.99.0/' \
+               ${RUBY_FAKEGEM_GEMSPEC} || die
 }