media-libs/zimg: bump to 2.4
authorAlexis Ballier <aballier@gentoo.org>
Mon, 23 Jan 2017 09:30:40 +0000 (10:30 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 23 Jan 2017 09:34:54 +0000 (10:34 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

media-libs/zimg/Manifest
media-libs/zimg/zimg-2.4.ebuild [new file with mode: 0644]
media-libs/zimg/zimg-9999.ebuild

index f07e992384e276fff797a36651a1d930e91fc7c5..f5638540b04eb8bbdd134712d5cc3216e59ed182 100644 (file)
@@ -1 +1,2 @@
 DIST zimg-2.3.tar.gz 188682 SHA256 09962385f986dbcfd8ed6160cdafc2bc57bef8c6bfb3ca3a4bcaa482f09c06fa SHA512 18ace0b66c59304d0a0abdb3cc4d5391bd1d74ef7b69af4e35350d452cf1b43807fc9ffda2285e991920bbb414e58a3e3a20d44a6f2ed7a9e902d956f973269d WHIRLPOOL 112b0f267587d361775d4eeab158cc66f8b56bbd760073d63417dd9f388de8df8758af07c7921b896dcef59f5e2fdf1474621f2bf22ca943473d268ee222611b
+DIST zimg-2.4.tar.gz 193791 SHA256 996ea0e446df6ff4d6cb9c04a77d60978eca47c32d3785cd63fe8c29a9523d1f SHA512 978a344c8f91327c7b92c6354526042d3901ce8ca3db19ba1ea1c81f4a1f980a64290223c202af354abd9efd821664d1743714acee171529a30f3742a0195e9e WHIRLPOOL cbae92a607d94c61860461d054e2a68220b2f7039e5aaade0dc869267795759076edd42bd30f4b03d816119b181a5c703a7d7382a7ff751433eace9d8050466b
diff --git a/media-libs/zimg/zimg-2.4.ebuild b/media-libs/zimg/zimg-2.4.ebuild
new file mode 100644 (file)
index 0000000..58109a1
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SCM="git-r3"
+       EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+       SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~ppc ~x86"
+       S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="static-libs cpu_flags_x86_sse"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+       autotools-multilib_src_configure \
+               $(use_enable cpu_flags_x86_sse x86simd)
+}
index a8a8647561d20c67afa6e980e136ea3a4c834c2a..58109a112c87ba7e56556f482401211fcc89adf9 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -20,7 +20,7 @@ HOMEPAGE="https://github.com/sekrit-twc/zimg"
 
 if [ "${PV#9999}" = "${PV}" ] ; then
        SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~ppc"
+       KEYWORDS="~amd64 ~ppc ~x86"
        S="${WORKDIR}/${PN}-release-${PV}/"
 fi