dev-ruby/facter: 3.14.10 stable amd64/x86 with 3.14.11 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 30 May 2020 17:18:17 +0000 (12:18 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 30 May 2020 17:18:47 +0000 (12:18 -0500)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-ruby/facter/Manifest
dev-ruby/facter/facter-3.14.10.ebuild
dev-ruby/facter/facter-3.14.11.ebuild [new file with mode: 0644]

index aba2c725447b9a122d34f8806ce288e1bacf3ef7..8daa73ed089ac70c9232f73a268c3ce0244a1579 100644 (file)
@@ -1,2 +1,3 @@
 DIST facter-3.14.10.tar.gz 406470 BLAKE2B ffd97f450676ad7465332f5159dc4fc9c695b9cbaaf8a09a2b575221bf11b11c044edeaab093f5222d64b0e7ef271d860072ab5435845ddff427714a4f2950e6 SHA512 e9f6b5a722982ad80282c355a82a5a6d302e6db36367d65701b7216f80032225da58106ccb025b742d2dc6ef98e2f5df5a07e53489802ee44603bc99ab930ffa
+DIST facter-3.14.11.tar.gz 406391 BLAKE2B 27606fe89fe9009db0ee14ccff6ad15db9fb548c25f752d044c0ec67bd772c1a523b2ec9d4fc49e5916b853ee119b7f640e2893b628e31fcaf2fc90e7edb3d81 SHA512 5e6a23f7ff91bfa2617c6afc15e441d1a61e9a1d57f4c7a1cfb033083ea0e2d72b348f06121a36c392b3ec64f08644832ef2d73c486def3e92edc7625ea62f51
 DIST facter-3.14.9.tar.gz 404448 BLAKE2B f95c0acce84013d58565193a35931d7f562639f607f3fed36ede5d2197336bec0ea4318a28ef29297150ab07a1fd35c292ca15c056b0b8cfe879bbebc64bfb18 SHA512 ff809c87641d65c43a9764d0a2cfe42f64c17d50e473a6d27b6ff25adfbd7be15edf25286932aeba348b669b05a11780257d41aa541fbb013c1169b6d8d25582
index b7819b83844f2cea5fa935cef19f11999bc5f70c..f2b40c9e3b7085f18c9d67e19f6266b25f95f7e3 100644 (file)
@@ -19,7 +19,7 @@ if [[ ${PV} == 9999 ]] ; then
        EGIT_BRANCH="master"
 else
        [[ "${PV}" = *_rc* ]] || \
-       KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+       KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
        SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 fi
 
diff --git a/dev-ruby/facter/facter-3.14.11.ebuild b/dev-ruby/facter/facter-3.14.11.ebuild
new file mode 100644 (file)
index 0000000..b7819b8
--- /dev/null
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+# git-r3 goes after ruby-ng so that it overrides src_unpack properly
+inherit cmake-utils eutils ruby-ng
+
+DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
+HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+if [[ ${PV} == 9999 ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
+       EGIT_BRANCH="master"
+else
+       [[ "${PV}" = *_rc* ]] || \
+       KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+       SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+RESTRICT="!test? ( test )"
+
+ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
+
+RDEPEND="
+       >=dev-cpp/cpp-hocon-0.2.1:=
+       >=dev-libs/leatherman-1.0.0:=
+       dev-libs/openssl:0=
+       sys-apps/util-linux
+       app-emulation/virt-what
+       net-misc/curl
+       dev-libs/boost:=[nls]
+       >=dev-cpp/yaml-cpp-0.5.1
+       !<app-admin/puppet-4.0.0"
+DEPEND="${RDEPEND}"
+
+# restore ${S} and override all phases exported by ruby-ng.eclass
+S="${WORKDIR}/${P}"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.14.6-fix-static-libcpp-hocon.patch
+       # be explicit about the version of rspec we test with
+       "${FILESDIR}"/${PN}-3.14.8-explicit-rspec-2.patch
+)
+
+pkg_setup() {
+       ruby-ng_pkg_setup
+}
+
+src_unpack() {
+       default
+
+       if [[ ${PV} == 9999 ]] ; then
+               git-r3_src_unpack
+       fi
+}
+
+src_prepare() {
+       cmake-utils_src_prepare
+}
+
+each_ruby_configure() {
+       # hack for correct calculation of relative path from facter.rb to
+       # libfacter.so
+       my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
+}
+
+src_configure() {
+       ruby-ng_src_configure
+
+       local mycmakeargs=(
+               -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
+               -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
+       )
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       addpredict /proc/self/oom_score_adj
+       cmake-utils_src_compile
+}
+
+src_test() {
+       cmake-utils_src_test
+}
+
+each_ruby_install() {
+       doruby "${BUILD_DIR}"/lib/facter.rb
+}
+
+src_install() {
+       cmake-utils_src_install
+       ruby-ng_src_install
+}