Skip the most expensive QA tests when --force in enabled since there's no point in...
authorZac Medico <zmedico@gentoo.org>
Tue, 28 Aug 2007 03:28:32 +0000 (03:28 -0000)
committerZac Medico <zmedico@gentoo.org>
Tue, 28 Aug 2007 03:28:32 +0000 (03:28 -0000)
svn path=/main/trunk/; revision=7713

bin/repoman

index 3c68088b3623739ec9c29b84b64554d550595256..a9540f534c7c68bb3b509527e2c3d2a08cceff44 100755 (executable)
@@ -1249,6 +1249,12 @@ for x in scanlist:
                                stats["usage.obsolete"] += 1
                                fails["usage.obsolete"].append("%s/%s.ebuild: not migrated to modular X" % (x, y))
 
+               if "--force" in myoptions:
+                       # The dep_check() calls are the most expensive QA test. If --force
+                       # is enabled, there's no point in wasting time on these since the
+                       # user is intent on forcing the commit anyway.
+                       continue
+
                for keyword,arch,groups in arches:
 
                        if not profiles.has_key(arch):