app-forensics/openscap: Drop old
authorPacho Ramos <pacho@gentoo.org>
Sun, 27 Jan 2019 09:50:13 +0000 (10:50 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 27 Jan 2019 10:15:19 +0000 (11:15 +0100)
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
app-forensics/openscap/Manifest
app-forensics/openscap/openscap-1.2.13.ebuild [deleted file]
app-forensics/openscap/openscap-1.2.5.ebuild [deleted file]

index fc59cd48a021111026789465b23cdda1fe19a67a..6d3afb4befae0312d74875d73b8b5f05b2c46aa4 100644 (file)
@@ -1,3 +1 @@
-DIST openscap-1.2.13.tar.gz 15874074 BLAKE2B 680a574cec7c8cd8e75dc91e4824735b09d2225ac91118897e569b2eb073959ea6d4a184fb79014aebe21d853ca01d2d36ed077050b82a2376066ad092bea170 SHA512 393b426f3278ab9438439df9a077b95b29bba66dfc2c799b7b40c2bf3980cf619aa1efc27225785ec780aa75926af6751b10fdb0b8d561c8056bf9a9a087792a
 DIST openscap-1.2.14.tar.gz 15980085 BLAKE2B 1d5d418b215f4a66a9f1874c4b9ed32c7c80e09d74a0ef04a256a7e1a24f1b675871116b0e22576dce476ee01c3d3b26ea5a48870a58aca99fdaea52c6877a7a SHA512 0e408b2dd58b8b424a27f5c852c6dc8c596fdb201e45cc5f762a1998e00511040762df4e55cdfd93dac4c820c28935acdf3942e96227dfa4f4363d682a2da7da
-DIST openscap-1.2.5.tar.gz 14513153 BLAKE2B bf7925fe17cb451f240ec50994f9291f55dbdb50c38872df0db1663a2d3f640e4d8bf1595d4fd7b46059ab43708e9340f4a1cced58029775f57f3b6d29a2eb30 SHA512 abeafafeaedd60ca08b52b981f83d458bc972894fc466d7cff29170b578a023f314bd330d7c812d838e09cad567ddc5daafa7e46e4b9a0db76451114d98d17ca
diff --git a/app-forensics/openscap/openscap-1.2.13.ebuild b/app-forensics/openscap/openscap-1.2.13.ebuild
deleted file mode 100644 (file)
index d2b7aa5..0000000
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit bash-completion-r1 eutils multilib python-single-r1
-
-DESCRIPTION="Framework which enables integration with Security Content Automation Protocol"
-HOMEPAGE="http://www.open-scap.org/"
-SRC_URI="https://github.com/OpenSCAP/${PN}/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="acl caps debug doc gconf ldap nss pcre perl python rpm selinux sce sql test xattr"
-RESTRICT="test"
-
-RDEPEND="!nss? ( dev-libs/libgcrypt:0 )
-       nss? ( dev-libs/nss )
-       acl? ( virtual/acl )
-       caps? ( sys-libs/libcap )
-       gconf? ( gnome-base/gconf )
-       ldap? ( net-nds/openldap )
-       pcre? ( dev-libs/libpcre )
-       rpm? ( >=app-arch/rpm-4.9 )
-       sql? ( dev-db/opendbx )
-       xattr? ( sys-apps/attr )
-       dev-libs/libpcre
-       dev-libs/libxml2
-       dev-libs/libxslt
-       net-misc/curl
-       ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
-       doc? ( app-doc/doxygen )
-       perl? ( dev-lang/swig )
-       python? ( dev-lang/swig )
-       test? (
-               app-arch/unzip
-               dev-perl/XML-XPath
-               net-misc/ipcalc
-               sys-apps/grep )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_prepare() {
-#      uncoment for debugging test
-#      sed -i 's,set -e,&;set -x,'     tests/API/XCCDF/unittests/test_remediate_simple.sh || die
-#      sed -i 's,^    bash,    LC_ALL=C bash,' tests/probes/process/test_probes_process.sh || die
-
-       sed -i 's/uname -p/uname -m/' tests/probes/uname/test_probes_uname.xml.sh || die
-
-       #probe runlevel for non-centos/redhat/fedora is not implemented
-       sed -i 's,.*runlevel_test.*,echo "runlevel test bypassed",' tests/mitre/test_mitre.sh || die
-       sed -i 's,probecheck "runlevel,probecheck "runlevellllll,' tests/probes/runlevel/test_probes_runlevel.sh || die
-
-       #According to comment of theses tests, we must modify it. For the moment disable it
-       sed -i 's,.*linux-def_inetlisteningservers_test,#&,' tests/mitre/test_mitre.sh || die
-       sed -i 's,.*ind-def_environmentvariable_test,#&,' tests/mitre/test_mitre.sh || die
-
-       # theses tests are hardcoded for checking hald process...,
-       # but no good solution for the moment, disabling them with a fake echo
-       # because encased in a if then
-#      sed -i 's,ha.d,/sbin/udevd --daemon,g' tests/mitre/unix-def_process_test.xml || die
-#      sed -i 's,ha.d,/sbin/udevd --daemon,g' tests/mitre/unix-def_process58_test.xml || die
-       sed -i 's,.*process_test.*,echo "process test bypassed",' tests/mitre/test_mitre.sh || die
-       sed -i 's,.*process58_test.*,echo "process58 test bypassed",' tests/mitre/test_mitre.sh || die
-
-       #This test fail
-       sed -i 's,.*generate report: xccdf,#&,' tests/API/XCCDF/unittests/all.sh ||     die
-
-       if ! use rpm ; then
-               sed -i 's,probe_rpminfo_req_deps_ok=yes,probe_rpminfo_req_deps_ok=no,' configure || die
-               sed -i 's,probe_rpminfo_opt_deps_ok=yes,probe_rpminfo_opt_deps_ok=no,' configure || die
-               sed -i 's,probe_rpmverify_req_deps_ok=yes,probe_rpmverify_req_deps_ok=no,' configure || die
-               sed -i 's,probe_rpmverify_opt_deps_ok=yes,probe_rpmverify_opt_deps_ok=no,' configure || die
-               sed -i 's,^probe_rpm.*_deps_missing=,&disabled_by_USE_flag,' configure || die
-               sed -i 's,.*rpm.*,#&,' tests/mitre/test_mitre.sh || die
-       fi
-       if ! use selinux ; then
-               einfo "Disabling SELinux probes"
-               sed -i 's,.*selinux.*,  echo "SELinux test bypassed",' tests/mitre/test_mitre.sh || die
-               #process58 need selinux
-               sed -i 's,.*process58,#&,' tests/mitre/test_mitre.sh || die
-       fi
-       if ! use ldap; then
-               einfo "Disabling LDAP probes"
-               sed -i 's,ldap.h,ldapp.h,g' configure || die
-       fi
-
-       epatch_user
-}
-
-src_configure() {
-       python_setup
-       local myconf
-       if use debug ; then
-               myconf+=" --enable-debug"
-       fi
-       if use python ; then
-               myconf+=" --enable-python"
-       else
-               myconf+=" --enable-python=no"
-       fi
-       if use perl ; then
-               myconf+=" --enable-perl"
-       fi
-       if use nss ; then
-               myconf+=" --with-crypto=nss3"
-       else
-               myconf+=" --with-crypto=gcrypt"
-       fi
-       if use sce ; then
-               myconf+=" --enable-sce"
-       else
-               myconf+=" --enable-sce=no"
-       fi
-       econf ${myconf}
-}
-
-src_compile() {
-       emake
-       if use doc ; then
-               cd docs && doxygen Doxyfile || die
-       fi
-}
-
-src_install() {
-       emake install DESTDIR="${D}"
-       prune_libtool_files --all
-       if use doc ; then
-               dohtml -r docs/html/.
-               dodoc -r docs/examples/.
-       fi
-       dobashcomp "${D}"/etc/bash_completion.d/oscap
-       rm -rf "${D}"/etc/bash_completion.d || die
-}
diff --git a/app-forensics/openscap/openscap-1.2.5.ebuild b/app-forensics/openscap/openscap-1.2.5.ebuild
deleted file mode 100644 (file)
index 444292a..0000000
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit bash-completion-r1 eutils multilib python-single-r1
-
-DESCRIPTION="Framework which enables integration with Security Content Automation Protocol"
-HOMEPAGE="http://www.open-scap.org/"
-SRC_URI="https://fedorahosted.org/releases/o/p/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="acl caps debug doc gconf ldap nss pcre perl python rpm selinux sce sql test xattr"
-RESTRICT="test"
-
-RDEPEND="!nss? ( dev-libs/libgcrypt:0 )
-       nss? ( dev-libs/nss )
-       acl? ( virtual/acl )
-       caps? ( sys-libs/libcap )
-       gconf? ( gnome-base/gconf )
-       ldap? ( net-nds/openldap )
-       pcre? ( dev-libs/libpcre )
-       rpm? ( >=app-arch/rpm-4.9 )
-       sql? ( dev-db/opendbx )
-       xattr? ( sys-apps/attr )
-       dev-libs/libpcre
-       dev-libs/libxml2
-       dev-libs/libxslt
-       net-misc/curl
-       ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
-       doc? ( app-doc/doxygen )
-       perl? ( dev-lang/swig )
-       python? ( dev-lang/swig )
-       test? (
-               app-arch/unzip
-               dev-perl/XML-XPath
-               net-misc/ipcalc
-               sys-apps/grep )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_prepare() {
-#      uncoment for debugging test
-#      sed -i 's,set -e,&;set -x,'     tests/API/XCCDF/unittests/test_remediate_simple.sh || die
-#      sed -i 's,^    bash,    LC_ALL=C bash,' tests/probes/process/test_probes_process.sh || die
-
-       sed -i 's/uname -p/uname -m/' tests/probes/uname/test_probes_uname.xml.sh || die
-
-       #probe runlevel for non-centos/redhat/fedora is not implemented
-       sed -i 's,.*runlevel_test.*,echo "runlevel test bypassed",' tests/mitre/test_mitre.sh || die
-       sed -i 's,probecheck "runlevel,probecheck "runlevellllll,' tests/probes/runlevel/test_probes_runlevel.sh || die
-
-       #According to comment of theses tests, we must modify it. For the moment disable it
-       sed -i 's,.*linux-def_inetlisteningservers_test,#&,' tests/mitre/test_mitre.sh || die
-       sed -i 's,.*ind-def_environmentvariable_test,#&,' tests/mitre/test_mitre.sh || die
-
-       # theses tests are hardcoded for checking hald process...,
-       # but no good solution for the moment, disabling them with a fake echo
-       # because encased in a if then
-#      sed -i 's,ha.d,/sbin/udevd --daemon,g' tests/mitre/unix-def_process_test.xml || die
-#      sed -i 's,ha.d,/sbin/udevd --daemon,g' tests/mitre/unix-def_process58_test.xml || die
-       sed -i 's,.*process_test.*,echo "process test bypassed",' tests/mitre/test_mitre.sh || die
-       sed -i 's,.*process58_test.*,echo "process58 test bypassed",' tests/mitre/test_mitre.sh || die
-
-       #This test fail
-       sed -i 's,.*generate report: xccdf,#&,' tests/API/XCCDF/unittests/all.sh ||     die
-
-       if ! use rpm ; then
-               sed -i 's,probe_rpminfo_req_deps_ok=yes,probe_rpminfo_req_deps_ok=no,' configure || die
-               sed -i 's,probe_rpminfo_opt_deps_ok=yes,probe_rpminfo_opt_deps_ok=no,' configure || die
-               sed -i 's,probe_rpmverify_req_deps_ok=yes,probe_rpmverify_req_deps_ok=no,' configure || die
-               sed -i 's,probe_rpmverify_opt_deps_ok=yes,probe_rpmverify_opt_deps_ok=no,' configure || die
-               sed -i 's,^probe_rpm.*_deps_missing=,&disabled_by_USE_flag,' configure || die
-               sed -i 's,.*rpm.*,#&,' tests/mitre/test_mitre.sh || die
-       fi
-       if ! use selinux ; then
-               einfo "Disabling SELinux probes"
-               sed -i 's,.*selinux.*,  echo "SELinux test bypassed",' tests/mitre/test_mitre.sh || die
-               #process58 need selinux
-               sed -i 's,.*process58,#&,' tests/mitre/test_mitre.sh || die
-       fi
-       if ! use ldap; then
-               einfo "Disabling LDAP probes"
-               sed -i 's,ldap.h,ldapp.h,g' configure || die
-       fi
-
-       epatch_user
-}
-
-src_configure() {
-       python_setup
-       local myconf
-       if use debug ; then
-               myconf+=" --enable-debug"
-       fi
-       if use python ; then
-               myconf+=" --enable-python"
-       else
-               myconf+=" --enable-python=no"
-       fi
-       if use perl ; then
-               myconf+=" --enable-perl"
-       fi
-       if use nss ; then
-               myconf+=" --with-crypto=nss3"
-       else
-               myconf+=" --with-crypto=gcrypt"
-       fi
-       if use sce ; then
-               myconf+=" --enable-sce"
-       else
-               myconf+=" --enable-sce=no"
-       fi
-       econf ${myconf}
-}
-
-src_compile() {
-       emake
-       if use doc ; then
-               cd docs && doxygen Doxyfile || die
-       fi
-}
-
-src_install() {
-       emake install DESTDIR="${D}"
-       prune_libtool_files --all
-       if use doc ; then
-               dohtml -r docs/html/.
-               dodoc docs/examples/.
-       fi
-       dobashcomp "${D}"/etc/bash_completion.d/oscap
-       rm -rf "${D}"/etc/bash_completion.d || die
-}