net-mail/notmuch: Update for elisp-common.eclass changes.
authorUlrich Müller <ulm@gentoo.org>
Sat, 21 Dec 2019 11:22:41 +0000 (12:22 +0100)
committerUlrich Müller <ulm@gentoo.org>
Sat, 21 Dec 2019 11:26:49 +0000 (12:26 +0100)
Function elisp-need-emacs is deprecated, replace it by assigning
NEED_EMACS and calling elisp-check-emacs-version in pkg_setup.

Require emacs-24.1 as minimum version, because it is the first version
with libxml2 support.

Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
net-mail/notmuch/notmuch-0.28.4.ebuild
net-mail/notmuch/notmuch-0.29.2.ebuild
net-mail/notmuch/notmuch-0.29.3.ebuild

index 2856cf698a2c840fcc0459914fba55de80ed98fd..c43123227e0c35f3e6a20c077c722287da3e1015 100644 (file)
@@ -38,7 +38,7 @@ CDEPEND="
        >=sys-libs/zlib-1.2.5.2
        sys-libs/talloc
        crypt? ( dev-libs/gmime:3.0[crypt] )
-       emacs? ( >=app-editors/emacs-23.1:* )
+       emacs? ( >=app-editors/emacs-24.1:* )
        python? ( ${PYTHON_DEPS} )
        "
 DEPEND="${CDEPEND}
@@ -49,7 +49,7 @@ DEPEND="${CDEPEND}
        )
        test? (
                app-misc/dtach
-               || ( >=app-editors/emacs-23[libxml2] >=app-editors/emacs-vcs-23[libxml2] )
+               >=app-editors/emacs-24.1:*[libxml2]
                sys-devel/gdb
                crypt? ( app-crypt/gnupg dev-libs/openssl )
        )
@@ -72,6 +72,7 @@ RDEPEND="${CDEPEND}
        "
 
 DOCS=( AUTHORS NEWS README )
+NEED_EMACS="24.1"
 SITEFILE="50${PN}-gentoo.el"
 MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
 PATCHES=(
@@ -104,9 +105,7 @@ pkg_pretend() {
 }
 
 pkg_setup() {
-       if use emacs; then
-               elisp-need-emacs 23 || die "Emacs version too low"
-       fi
+       use emacs && elisp-check-emacs-version
 }
 
 src_unpack() {
index f848c35df5ec21104a81bc8fa62aca1607dcc92b..4ee535926dd5e12d4c955fa2dc8ee84d4372b8ab 100644 (file)
@@ -38,7 +38,7 @@ CDEPEND="
        >=sys-libs/zlib-1.2.5.2
        sys-libs/talloc
        crypt? ( dev-libs/gmime:3.0[crypt] )
-       emacs? ( >=app-editors/emacs-23.1:* )
+       emacs? ( >=app-editors/emacs-24.1:* )
        python? ( ${PYTHON_DEPS} )
        "
 DEPEND="${CDEPEND}
@@ -49,7 +49,7 @@ DEPEND="${CDEPEND}
        )
        test? (
                app-misc/dtach
-               || ( >=app-editors/emacs-23[libxml2] >=app-editors/emacs-vcs-23[libxml2] )
+               >=app-editors/emacs-24.1:*[libxml2]
                sys-devel/gdb
                crypt? ( app-crypt/gnupg dev-libs/openssl )
        )
@@ -72,6 +72,7 @@ RDEPEND="${CDEPEND}
        "
 
 DOCS=( AUTHORS NEWS README )
+NEED_EMACS="24.1"
 SITEFILE="50${PN}-gentoo.el"
 MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
 PATCHES=(
@@ -103,9 +104,7 @@ pkg_pretend() {
 }
 
 pkg_setup() {
-       if use emacs; then
-               elisp-need-emacs 23 || die "Emacs version too low"
-       fi
+       use emacs && elisp-check-emacs-version
 }
 
 src_unpack() {
index f848c35df5ec21104a81bc8fa62aca1607dcc92b..4ee535926dd5e12d4c955fa2dc8ee84d4372b8ab 100644 (file)
@@ -38,7 +38,7 @@ CDEPEND="
        >=sys-libs/zlib-1.2.5.2
        sys-libs/talloc
        crypt? ( dev-libs/gmime:3.0[crypt] )
-       emacs? ( >=app-editors/emacs-23.1:* )
+       emacs? ( >=app-editors/emacs-24.1:* )
        python? ( ${PYTHON_DEPS} )
        "
 DEPEND="${CDEPEND}
@@ -49,7 +49,7 @@ DEPEND="${CDEPEND}
        )
        test? (
                app-misc/dtach
-               || ( >=app-editors/emacs-23[libxml2] >=app-editors/emacs-vcs-23[libxml2] )
+               >=app-editors/emacs-24.1:*[libxml2]
                sys-devel/gdb
                crypt? ( app-crypt/gnupg dev-libs/openssl )
        )
@@ -72,6 +72,7 @@ RDEPEND="${CDEPEND}
        "
 
 DOCS=( AUTHORS NEWS README )
+NEED_EMACS="24.1"
 SITEFILE="50${PN}-gentoo.el"
 MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
 PATCHES=(
@@ -103,9 +104,7 @@ pkg_pretend() {
 }
 
 pkg_setup() {
-       if use emacs; then
-               elisp-need-emacs 23 || die "Emacs version too low"
-       fi
+       use emacs && elisp-check-emacs-version
 }
 
 src_unpack() {