net-mail/notmuch: Bump version
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>
Sun, 7 Jul 2019 10:36:42 +0000 (11:36 +0100)
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>
Sun, 7 Jul 2019 10:40:15 +0000 (11:40 +0100)
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Amadeusz Piotr Żołnowski <aidecoe@gentoo.org>
net-mail/notmuch/Manifest
net-mail/notmuch/files/0.29.1-0001-Use-loopback-IP-address-rather-than-name.patch [new file with mode: 0644]
net-mail/notmuch/notmuch-0.29.1.ebuild [new file with mode: 0644]

index 353a9c085dcbaa30422857f60839e09e93ad5e49..32f46df03f9c1ab7c9da6c3ce8b1de62cd59f1f8 100644 (file)
@@ -7,3 +7,4 @@ DIST notmuch-0.26.2.tar.gz 907187 BLAKE2B 81212555d729bd05be2edfb0f3dfd604de9d5f
 DIST notmuch-0.27.tar.gz 912583 BLAKE2B 75bb13e9666bd2898f58e5ecdd6a180d0da21188665f107857e6729f057525bb7c94832d140de8ff7b3fd31b51e33bcbe5b59d3fc09ba9a854c1c05499df762e SHA512 7c58c6fe5c3b43a979c3a439a24106417120726fd688b456d9084388ddd7c88ab1b6d99cd4676101f085d60bb37099631caa286b76588fcb041bb004ff325515
 DIST notmuch-0.28.3.tar.gz 921920 BLAKE2B 9b96a0cac8188bcaf9efab532721449c655fec4dac77c3eb327e576184cb430aa0fffc9ac74af82ad3ad80097afdda5c8accddbee7e5720d180c071d9dd2ef85 SHA512 dd3931b78cc27540e962f1fca5f4ebb1c04b2637a5761cda023f307fd9be4b5ddc2af26010330868c55200fa96b60b2a11b3b22d4c20d2a4a2d3787421ed85cf
 DIST notmuch-0.28.4.tar.gz 922364 BLAKE2B f22d52ecc982b086b5d2a67d3b9ae4a379bdcb9e9acf3e77060fd7d97439347e3b4cd767f2c9c3c48657b80f63316f6abc09a653d6791e27b4a8996adccf42a9 SHA512 77d7ad81e1f7dc93ae6392346da434f6dc74c21d19be728c2a6ca283c429f36e7081387d223af58eb5f63f5d2a8ad8367f0103f0bb9d052890c07fe419abbee7
+DIST notmuch-0.29.1.tar.xz 660352 BLAKE2B d145aba2d1a376e8cbcff3d51f9a7093649912a54273f91cce2a56fb414e222c2bbf0aeb510894278bf7dca8a96412400d55897a4d42281ab9c110d9bc8207a6 SHA512 9b76a7c8c62cb67b64a0008f80a82eeecccd20267ddba67d4d96a768815466c305f154769947bb9526e02c7a1696faaf69e94b90007603b185589be0c7c2a5d8
diff --git a/net-mail/notmuch/files/0.29.1-0001-Use-loopback-IP-address-rather-than-name.patch b/net-mail/notmuch/files/0.29.1-0001-Use-loopback-IP-address-rather-than-name.patch
new file mode 100644 (file)
index 0000000..e472246
--- /dev/null
@@ -0,0 +1,61 @@
+From 59b5bfb6e2095c62925b31e087571506edae7956 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20Piotr=20=C5=BBo=C5=82nowski?=
+ <aidecoe@aidecoe.name>
+Date: Sun, 7 Jul 2019 11:33:09 +0100
+Subject: [PATCH] Use loopback IP address rather than name
+
+---
+ test/smtp-dummy.c | 8 ++++----
+ test/test-lib.sh  | 2 +-
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/test/smtp-dummy.c b/test/smtp-dummy.c
+index a7c1fe4f..822a986a 100644
+--- a/test/smtp-dummy.c
++++ b/test/smtp-dummy.c
+@@ -76,7 +76,7 @@ process_command (FILE *peer, FILE *output, const char *command)
+       fprintf (peer, "502 not implemented\r\n");
+       fflush (peer);
+     } else if (STRNCMP_LITERAL (command, "HELO ") == 0) {
+-      fprintf (peer, "250 localhost\r\n");
++      fprintf (peer, "250 127.0.0.1\r\n");
+       fflush (peer);
+     } else if (STRNCMP_LITERAL (command, "MAIL FROM:") == 0 ||
+              STRNCMP_LITERAL (command, "RCPT TO:") == 0) {
+@@ -105,7 +105,7 @@ do_smtp_to_file (FILE *peer, FILE *output)
+     size_t line_size;
+     ssize_t line_len;
+-    fprintf (peer, "220 localhost smtp-dummy\r\n");
++    fprintf (peer, "220 127.0.0.1 smtp-dummy\r\n");
+     fflush (peer);
+     while ((line_len = getline (&line, &line_size, peer)) != -1) {
+@@ -183,9 +183,9 @@ main (int argc, char *argv[])
+       goto DONE;
+     }
+-    hostinfo = gethostbyname ("localhost");
++    hostinfo = gethostbyname ("127.0.0.1");
+     if (hostinfo == NULL) {
+-      fprintf (stderr, "Unknown host: localhost\n");
++      fprintf (stderr, "Unknown host: 127.0.0.1\n");
+       ret = 1;
+       goto DONE;
+     }
+diff --git a/test/test-lib.sh b/test/test-lib.sh
+index 616cb674..dd887773 100644
+--- a/test/test-lib.sh
++++ b/test/test-lib.sh
+@@ -336,7 +336,7 @@ emacs_deliver_message ()
+     test_emacs \
+       "(let ((message-send-mail-function 'message-smtpmail-send-it)
+              (mail-host-address \"example.com\")
+-             (smtpmail-smtp-server \"localhost\")
++             (smtpmail-smtp-server \"127.0.0.1\")
+              (smtpmail-smtp-service \"${smtp_dummy_port}\"))
+          (notmuch-mua-mail)
+          (message-goto-to)
+-- 
+2.19.2
+
diff --git a/net-mail/notmuch/notmuch-0.29.1.ebuild b/net-mail/notmuch/notmuch-0.29.1.ebuild
new file mode 100644 (file)
index 0000000..ffa7470
--- /dev/null
@@ -0,0 +1,230 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
+       distutils-r1 toolchain-funcs
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="https://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.xz
+       test? ( ${HOMEPAGE%/}/releases/test-databases/database-v1.tar.xz )"
+
+LICENSE="GPL-3"
+# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y.  Bump of Y is
+# meant to be binary backward compatible.
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~x86 ~x64-solaris"
+REQUIRED_USE="
+       nmbug? ( python )
+       python? ( ${PYTHON_REQUIRED_USE} )
+       test? ( crypt emacs python valgrind )
+       "
+IUSE="crypt doc emacs mutt nmbug python test valgrind"
+
+CDEPEND="
+       !!<app-shells/bash-completion-1.9
+       >=dev-libs/glib-2.22:2
+       >=dev-libs/gmime-3.0.3:3.0
+       >=dev-libs/xapian-1.4.8:=
+       dev-python/sphinx[${PYTHON_USEDEP}]
+       sys-apps/texinfo
+       >=sys-libs/zlib-1.2.5.2
+       sys-libs/talloc
+       crypt? ( dev-libs/gmime:3.0[crypt] )
+       emacs? ( >=virtual/emacs-23 )
+       python? ( ${PYTHON_DEPS} )
+       "
+DEPEND="${CDEPEND}
+       virtual/pkgconfig
+       doc? (
+               app-doc/doxygen
+               dev-python/mock[${PYTHON_USEDEP}]
+       )
+       test? (
+               app-misc/dtach
+               || ( >=app-editors/emacs-23[libxml2] >=app-editors/emacs-vcs-23[libxml2] )
+               sys-devel/gdb
+               crypt? ( app-crypt/gnupg dev-libs/openssl )
+       )
+       valgrind? ( dev-util/valgrind )
+       "
+RDEPEND="${CDEPEND}
+       crypt? ( app-crypt/gnupg )
+       nmbug? ( dev-vcs/git )
+       mutt? (
+               dev-perl/File-Which
+               dev-perl/Mail-Box
+               dev-perl/MailTools
+               dev-perl/String-ShellQuote
+               dev-perl/Term-ReadLine-Gnu
+               virtual/perl-Digest-SHA
+               virtual/perl-File-Path
+               virtual/perl-Getopt-Long
+               virtual/perl-Pod-Parser
+       )
+       "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+PATCHES=(
+       "${FILESDIR}"/${PV}-0001-Use-loopback-IP-address-rather-than-name.patch
+)
+
+bindings() {
+       local ret=0
+
+       if use $1; then
+               pushd bindings/$1 || die
+               shift
+               "$@"
+               ret=$?
+               popd || die
+       fi
+
+       return $ret
+}
+
+pkg_pretend() {
+       if has_version '<net-mail/notmuch-0.18'; then
+               ewarn
+               ewarn "There are few not backward compatible changes between"
+               ewarn "<notmuch-0.18 and >=notmuch-0.18.  See NEWS file"
+               ewarn "(0.18 section) for details before first use!"
+               ewarn
+       fi
+}
+
+pkg_setup() {
+       if use emacs; then
+               elisp-need-emacs 23 || die "Emacs version too low"
+       fi
+}
+
+src_unpack() {
+       unpack "${P}".tar.xz
+       if use test; then
+               mkdir -p "${S}"/test/test-databases || die
+               cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
+       fi
+}
+
+src_prepare() {
+       default
+
+       bindings python distutils-r1_src_prepare
+       bindings python mv README README-python || die
+       mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+
+       # assure that new Makefile.config will be generated
+       rm -f Makefile.config || die
+
+       sed -e 's@^install: all install-man install-info$@install: all install-info@' -i Makefile.local
+
+       if use test; then
+               append-cflags -g
+               append-cxxflags -g
+       fi
+
+       [[ ${CHOST} == *-solaris* ]] && append-ldflags -lnsl -lsocket
+}
+
+src_configure() {
+       python_setup  # for sphinx
+
+       local myeconfargs=(
+               --bashcompletiondir="$(get_bashcompdir)"
+               --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
+               --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
+               --without-desktop
+               --without-ruby
+               --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+               $(use_with emacs)
+               $(use_with doc api-docs)
+       )
+       tc-export CC CXX
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       python_setup  # for sphinx
+
+       V=1 default
+       bindings python distutils-r1_src_compile
+
+       if use mutt; then
+               pushd contrib/notmuch-mutt || die
+               emake notmuch-mutt.1
+               popd || die
+       fi
+
+       if use doc; then
+               pydocs() {
+                       pushd docs || die
+                       emake html
+                       rm -r html/_sources || die
+                       rm html/{objects.inv,.buildinfo} || die
+                       mkdir -p ../html && mv html ../html/python || die
+                       popd || die
+               }
+               LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+       fi
+}
+
+src_test() {
+       pax-mark -m notmuch
+       LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" V=1 default
+       pax-mark -ze notmuch
+}
+
+src_install() {
+       default
+
+       if use doc; then
+               doman doc/_build/man/man?/*.?
+       fi
+
+       if use emacs; then
+               elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+       fi
+
+       if use nmbug; then
+               dobin devel/nmbug/nmbug
+               dobin devel/nmbug/notmuch-report
+       fi
+
+       if use mutt; then
+               pushd contrib/notmuch-mutt || die
+               dobin notmuch-mutt
+               doman notmuch-mutt.1
+               insinto /etc/mutt
+               doins notmuch-mutt.rc
+               dodoc README-mutt
+               popd || die
+       fi
+
+       DOCS="" bindings python distutils-r1_src_install
+       use doc && bindings python dodoc -r html
+}
+
+pkg_preinst() {
+       if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
+               elog "To enable notmuch support in mutt, add the following line into"
+               elog "your mutt config file, please:"
+               elog ""
+               elog "  source /etc/mutt/notmuch-mutt.rc"
+       fi
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}