Version bump. Adds support for src_test and the source use flag. Fixes bug #129511.
authorPetteri Räty <betelgeuse@gentoo.org>
Tue, 16 Jan 2007 18:00:58 +0000 (18:00 +0000)
committerPetteri Räty <betelgeuse@gentoo.org>
Tue, 16 Jan 2007 18:00:58 +0000 (18:00 +0000)
Package-Manager: portage-2.1.2

dev-java/commons-pool/ChangeLog
dev-java/commons-pool/commons-pool-1.3.ebuild [new file with mode: 0644]
dev-java/commons-pool/files/digest-commons-pool-1.1
dev-java/commons-pool/files/digest-commons-pool-1.3 [new file with mode: 0644]

index bd7948d967c274347736c5335aaf9148af161f65..21947eaee3c49fa172254f8dec189cc304d693b5 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for dev-java/commons-pool
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.34 2006/12/09 09:15:56 flameeyes Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.35 2007/01/16 18:00:58 betelgeuse Exp $
+
+*commons-pool-1.3 (16 Jan 2007)
+
+  16 Jan 2007; Petteri Räty <betelgeuse@gentoo.org>
+  +commons-pool-1.3.ebuild:
+  Version bump. Adds support for src_test and the source use flag. Fixes bug
+  #129511.
 
   09 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
   commons-pool-1.2-r2.ebuild:
diff --git a/dev-java/commons-pool/commons-pool-1.3.ebuild b/dev-java/commons-pool/commons-pool-1.3.ebuild
new file mode 100644 (file)
index 0000000..9aaf393
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.3.ebuild,v 1.1 2007/01/16 18:00:58 betelgeuse Exp $
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Jakarta-Commons component providing general purpose object pooling API"
+HOMEPAGE="http://jakarta.apache.org/commons/pool/"
+SRC_URI="mirror://apache/jakarta/commons/pool/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="doc source test"
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4
+       >=dev-java/ant-core-1.4
+       test? ( >=dev-java/junit-3.7 )"
+
+S="${WORKDIR}/${P}-src"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       rm -v *.jar
+}
+
+EANT_BUILD_TARGET="build-jar"
+
+src_test() {
+       echo "junit.jar=$(java-pkg_getjars junit)" >> build.properties
+       eant test
+}
+
+src_install() {
+       java-pkg_newjar dist/${P}.jar
+       dodoc README.txt NOTICE.txt RELEASE-NOTES.txt
+
+       use doc && java-pkg_dojavadoc dist/docs/api
+       use source && java-pkg_dosrc src/java/org
+}
index 1b2bc092c4807dc91c83e6238305b3f4e7757b4f..17cd85dd47bb90dfcbdd5acb2448129a4344cf7d 100644 (file)
@@ -1 +1,3 @@
 MD5 344b568101f56cf5bc73d43e6fbe5892 commons-pool-1.1-src.tar.gz 46476
+RMD160 425c198447d6138decc978846597b240fd2a8a4d commons-pool-1.1-src.tar.gz 46476
+SHA256 c58d5f9f880c3a4538b3050d763146aeb31275347cb1a9fe126e5669a348cacf commons-pool-1.1-src.tar.gz 46476
diff --git a/dev-java/commons-pool/files/digest-commons-pool-1.3 b/dev-java/commons-pool/files/digest-commons-pool-1.3
new file mode 100644 (file)
index 0000000..12e56b9
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 a2dcdff75de2af76f5f2169494ed3499 commons-pool-1.3-src.tar.gz 305175
+RMD160 a4fa896fd03a2285198495ccda5499b270eba686 commons-pool-1.3-src.tar.gz 305175
+SHA256 28c055168601cc57c8a4cff360b79b6409fabfd7275605031c43c7b06b978add commons-pool-1.3-src.tar.gz 305175