dev-python/aiohttp-cors: 0.7.0 version bump, EAPI=7
authorCraig Andrews <candrews@gentoo.org>
Sun, 13 Oct 2019 20:47:04 +0000 (16:47 -0400)
committerCraig Andrews <candrews@gentoo.org>
Tue, 15 Oct 2019 15:57:53 +0000 (11:57 -0400)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-python/aiohttp-cors/Manifest
dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild [new file with mode: 0644]

index 0befccb4462bd7b03ee01f01ec006633cc0f3d2d..2b70a08370e55ed8232b610ea8672832a1681261 100644 (file)
@@ -1 +1,2 @@
 DIST aiohttp-cors-0.6.0.tar.gz 42507 BLAKE2B 7b63916b983d3dc208058c8b04445a30762eebc4999135ae802d1ceeeccc476a335eae66126bb3fd16f938af3649e8b9096433c2df09e82bf4e5d4ba8e38c42c SHA512 75453ebbc074d5f25cc8efc46ffdb76fc90b0a96a9e6fce0eee5a5f28dba31cb50301289cac3b36c70ccdbc10c8f4ba9e362d8e9f350ba7f9dfacd06e6f5e699
+DIST aiohttp-cors-0.7.0.tar.gz 39728 BLAKE2B 747499856272f551cf8e2e0911ff7cbb2c7cb8a1f3159327dd8f0d40cabbbd9713a1a9e30ef9c99f3f9642567c99025e049db837c89f907d6698a27005ac2632 SHA512 72e0b365b952c08a02c1123d7672cfea01063e2ff01743a71e10f804d22178edc0f1c6b7f87b7ed484ca7c24e89a32de90d0d279f2f5c060427319182f9bdd3b
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild
new file mode 100644 (file)
index 0000000..6bd3345
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-cors"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp-cors"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pylint[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-cov[${PYTHON_USEDEP}]
+               dev-python/pytest-pylint[${PYTHON_USEDEP}]
+               dev-python/pytest-runner[${PYTHON_USEDEP}]
+               dev-python/selenium[${PYTHON_USEDEP}]
+       )"
+
+python_prepare_all() {
+       # for some reason, it is installed by 'setup.py test' on py!=3.4
+       # TODO: investigate
+       sed -i -e '/typing/d' setup.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       esetup.py test
+}