dev-ros/geodesy: Bump to 0.5.0.
authorAlexis Ballier <aballier@gentoo.org>
Sat, 8 Apr 2017 08:19:08 +0000 (10:19 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 8 Apr 2017 09:20:51 +0000 (11:20 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-ros/geodesy/Manifest
dev-ros/geodesy/geodesy-0.5.0.ebuild [new file with mode: 0644]

index ffc2215dc00f7a6febe6a2a10463e5906073f0d1..22a95043b0cadba5253b4c164866af0d1c9538a7 100644 (file)
@@ -1 +1,2 @@
 DIST geographic_info-0.4.0.tar.gz 26981 SHA256 7e31afeeb319e67242304445b690f345d6b66993ab0be582e36a454f7ac8eca4 SHA512 1296ad824caacf0a1240468dbc979c647e8d412246ca8aae19f2091487ab2b9c9ec2c3fe3f3eb92f0b662f318b005a34072555bad6b3d979c1463464f303764d WHIRLPOOL d9865cea02597df7421739c56fc32fd3029c0ebf6a1558a4ee701cb0025269bdb6c735598c0aa411aa7736bfb10fdd554842b7c2e1c96e3b2ebb28a6686e50f6
+DIST geographic_info-0.5.0.tar.gz 27102 SHA256 83e046fe4fa92fc9a63727ab8699c0c833f8759ae09c4d07b2c1fd698c73eceb SHA512 c6c4937a7c9873c071be9e3fc4fcdb99f831028dce93793e537f8819e2fb8633b995e7d46d7192ddc3457a3b79d27c54c3e0b6656af30e2daabf1f0e7dff9f05 WHIRLPOOL a6c9f2e6341d1e1e313230bc3f45b8e3d4c0821d1c29ca38e47f8a276d1154d05b3731935efd44722d9f67fa2665ed2db822edc08a3a13a0801a4794443a1ae0
diff --git a/dev-ros/geodesy/geodesy-0.5.0.ebuild b/dev-ros/geodesy/geodesy-0.5.0.ebuild
new file mode 100644 (file)
index 0000000..d04b778
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
+VER_PREFIX=geographic_info-
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ interfaces for manipulating geodetic coordinates"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/angles
+       dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/tf
+       dev-ros/unique_id
+       dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-python/pyproj[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       test? (
+               dev-ros/rosunit[${PYTHON_USEDEP}]
+               dev-cpp/gtest
+               dev-python/nose[${PYTHON_USEDEP}]
+       )"