dev-libs/protobuf-c: Fix building with >=dev-libs/protobuf-3.7.
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Sun, 5 May 2019 01:54:51 +0000 (03:54 +0200)
committerMike Gilbert <floppym@gentoo.org>
Sun, 5 May 2019 19:04:00 +0000 (15:04 -0400)
Fixes: https://bugs.gentoo.org/684028
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-libs/protobuf-c/files/protobuf-c-1.3.1-protobuf-3.7.patch [new file with mode: 0644]
dev-libs/protobuf-c/protobuf-c-1.3.1.ebuild

diff --git a/dev-libs/protobuf-c/files/protobuf-c-1.3.1-protobuf-3.7.patch b/dev-libs/protobuf-c/files/protobuf-c-1.3.1-protobuf-3.7.patch
new file mode 100644 (file)
index 0000000..218dec0
--- /dev/null
@@ -0,0 +1,13 @@
+https://github.com/protobuf-c/protobuf-c/commit/7456d1621223d425b8a3fd74e435a79c046169fb
+
+--- /t/generated-code2/cxx-generate-packed-data.cc
++++ /t/generated-code2/cxx-generate-packed-data.cc
+@@ -998,7 +998,7 @@
+ static void dump_test_unknown_fields (void)
+ {
+   EmptyMess mess;
+-  const google::protobuf::Message::Reflection *reflection = mess.GetReflection();
++  const google::protobuf::Reflection *reflection = mess.GetReflection();
+   google::protobuf::UnknownFieldSet *fs = reflection->MutableUnknownFields(&mess);
+ #if GOOGLE_PROTOBUF_VERSION >= 2001000
index b5226f546288d7c001f1481726f6093c17c381f6..8bc5d70da05fb1339a1665bdbf234cd260342317 100644 (file)
@@ -24,6 +24,10 @@ DEPEND="${RDEPEND}
 
 S="${WORKDIR}/${MY_P}"
 
+PATCHES=(
+       "${FILESDIR}/${PN}-1.3.1-protobuf-3.7.patch"
+)
+
 src_prepare() {
        default
        if ! use test; then