app-misc/astrolog-ephemeris: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Wed, 16 Oct 2019 10:18:07 +0000 (12:18 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 16 Oct 2019 10:18:07 +0000 (12:18 +0200)
Closes: https://bugs.gentoo.org/697396
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
app-misc/astrolog-ephemeris/astrolog-ephemeris-5.40.ebuild

index 0e79b4d13905531132d7fba0b02a57f9d93460e1..269fbde6ea43241ba8a7e4741f5e956192dd68a6 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 DESCRIPTION="ephemeris files for optional extended accuracy of astrolog's calculations"
 HOMEPAGE="http://www.astrolog.org/astrolog.htm"
@@ -16,10 +16,9 @@ IUSE=""
 S="${WORKDIR}"
 
 RDEPEND="app-misc/astrolog"
-DEPEND="${RDEPEND}
-       app-arch/unzip"
+BDEPEND="app-arch/unzip"
 
 src_install() {
-       dodir /usr/share/astrolog
-       cp * "${D}"/usr/share/astrolog || die "cp failed"
+       insinto /usr/share/astrolog
+       doins -r .
 }