games-puzzle/galaxis: Fixed build with sys-libs/ncurses[tinfo]
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 18 Jul 2019 12:47:01 +0000 (14:47 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 18 Jul 2019 12:47:01 +0000 (14:47 +0200)
Closes: https://bugs.gentoo.org/690080
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
games-puzzle/galaxis/galaxis-1.8-r1.ebuild

index 73020c4a91e1f090cbfd81dd2c306200d7f02254..d646f5a94a2b93b23e00bbf0ba1a9fd9ce8ae9d3 100644 (file)
@@ -1,7 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
 
 DESCRIPTION="Curses-based clone of the nifty little Macintosh freeware game Galaxis"
 HOMEPAGE="http://www.catb.org/~esr/galaxis/"
@@ -14,9 +16,15 @@ IUSE=""
 
 DEPEND=">=sys-libs/ncurses-5.3:0="
 RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
 
 PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
 
+src_compile() {
+       local PKGCONFIG="$(tc-getPKG_CONFIG)"
+       emake TERMLIB="$(${PKGCONFIG} --libs ncurses)"
+}
+
 src_install() {
        dobin galaxis
        doman galaxis.6