Fix invalid use of autotools-utils.eclass.
authorMichał Górny <mgorny@gentoo.org>
Thu, 12 Jan 2012 16:34:10 +0000 (16:34 +0000)
committerMichał Górny <mgorny@gentoo.org>
Thu, 12 Jan 2012 16:34:10 +0000 (16:34 +0000)
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64

app-accessibility/sphinx3/ChangeLog
app-accessibility/sphinx3/sphinx3-0.8.ebuild
app-accessibility/sphinxbase/ChangeLog
app-accessibility/sphinxbase/sphinxbase-0.7.ebuild

index 62090c55be5a4e732c314132d05ee51f9a791a50..4905e1911b922883007ba64a43f7bf06ee789fe3 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for app-accessibility/sphinx3
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx3/ChangeLog,v 1.5 2011/11/17 17:45:56 neurogeek Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx3/ChangeLog,v 1.6 2012/01/12 16:34:10 mgorny Exp $
+
+  12 Jan 2012; Michał Górny <mgorny@gentoo.org> sphinx3-0.8.ebuild:
+  Fix invalid use of autotools-utils.eclass.
 
 *sphinx3-0.8 (17 Nov 2011)
 
index 08fa4df81c444c798277e5a2da1267915cd3aad8..33a7955795183d06181ef8daac03982f731e70eb 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx3/sphinx3-0.8.ebuild,v 1.1 2011/11/17 17:45:56 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx3/sphinx3-0.8.ebuild,v 1.2 2012/01/12 16:34:10 mgorny Exp $
 
 EAPI=3
 PYTHON_DEPEND="python? 2:2.6"
@@ -22,18 +22,16 @@ RDEPEND="${DEPEND}"
 
 RESTRICT_PYTHON_ABIS="3*"
 
+# Due to generated Python setup.py.
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
 src_prepare() {
        epatch "${FILESDIR}/${P}_heap_fix.patch"
        eprefixify 'python/setup.py'
 }
 
-src_configure() {
-       econf \
-               $( use_enable static-libs static )
-}
-
 src_compile() {
-       default
+       autotools-utils_src_compile
 
        if use python; then
                python_copy_sources python
@@ -47,9 +45,8 @@ src_compile() {
 }
 
 src_install() {
-       emake DESTDIR="${D}" install || die
-
-       dodoc AUTHORS ChangeLog NEWS README
+       local DOCS=( AUTHORS ChangeLog NEWS README )
+       autotools-utils_src_install
 
        if use doc; then
                cd doc
@@ -57,7 +54,6 @@ src_install() {
        fi
 
        if use python; then
-
                installing() {
                        "$(PYTHON)" setup.py install \
                                --install-lib="${D}/$(python_get_sitedir)"
@@ -65,6 +61,4 @@ src_install() {
 
                python_execute_function -s --source-dir python installing
        fi
-
-       remove_libtool_files
 }
index 9f422183eeb147f5c4ba13cee1fd38406df29d84..619737915f7c13c817de7ccd86752ff3f1a70ac8 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for app-accessibility/sphinxbase
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinxbase/ChangeLog,v 1.1 2011/11/17 17:35:05 neurogeek Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinxbase/ChangeLog,v 1.2 2012/01/12 16:33:37 mgorny Exp $
+
+  12 Jan 2012; Michał Górny <mgorny@gentoo.org> sphinxbase-0.7.ebuild:
+  Fix invalid use of autotools-utils.eclass.
 
 *sphinxbase-0.7 (17 Nov 2011)
 
index 5262b6dc5ebdd7fbd63b5cbdd329848f74d0fac2..90da48e0a88dea1ce6db24a8f0bb3400d6f22bc3 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinxbase/sphinxbase-0.7.ebuild,v 1.1 2011/11/17 17:35:05 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinxbase/sphinxbase-0.7.ebuild,v 1.2 2012/01/12 16:33:37 mgorny Exp $
 
 EAPI=3
 PYTHON_DEPEND="python? 2:2.6"
@@ -23,15 +23,22 @@ DEPEND="${RDEPEND}
 
 RESTRICT_PYTHON_ABIS="3*"
 
+# Due to generated Python setup.py.
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
 src_configure() {
-       econf \
-               $( use_with lapack ) \
-               $( use_with python ) \
-               $( use_enable static-libs static )
+       local myeconfargs=(
+               $( use_with lapack )
+               # python modules are built through distutils
+               # so disable the ugly wrapper
+               --without-python
+       )
+
+       autotools-utils_src_configure
 }
 
 src_compile() {
-       default
+       autotools-utils_src_compile
 
        if use python; then
                python_copy_sources python
@@ -45,7 +52,7 @@ src_compile() {
 }
 
 src_install() {
-       emake DESTDIR="${D}" install || die
+       autotools-utils_src_install
 
        if use python; then
                python_execute_function -s --source-dir python -d
@@ -54,6 +61,4 @@ src_install() {
        if use doc; then
                dohtml doc/html/*
        fi
-
-       remove_libtool_files
 }