net-im/telegram-desktop: drop old
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 24 Apr 2020 19:59:43 +0000 (12:59 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 24 Apr 2020 20:01:35 +0000 (13:01 -0700)
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
net-im/telegram-desktop/Manifest
net-im/telegram-desktop/files/1.9.21-icon.patch [deleted file]
net-im/telegram-desktop/telegram-desktop-1.9.21.ebuild [deleted file]

index 76099ebd88ff1c97118c6e771fd71bc5db483dd5..027ce25108878c76525563730079eda377c3b577 100644 (file)
@@ -1,3 +1,2 @@
-DIST tdesktop-1.9.21-full.tar.gz 25848026 BLAKE2B 503e22bcc83a64721aa4c4c6e8bca89c4c976703c338b1615c5ab1599098e98cbd220a94cffdbe24d9c305b44ffef7719ad1c2d2ad81f4ec6edc8377e1afa4ef SHA512 ea02fc69e88ed6244ed420516bb7a93827cb85efaa0a7e9af7562aa1bc29184c5a2102caca8693c976b25d374832e0deb2ccbf00144d5340b5ffacbdc9dcebf1
 DIST tdesktop-2.0.1-full.tar.gz 26106949 BLAKE2B 3975e7d42af8b323a86408e2301b292d94b308413bb92d135673fb12851cd6672156dcf9b631482fa9b8dc9361d9593dc1104c8c335e0c610706b308414db01b SHA512 99cd7c5ca1e9dd75ecd98d272522b0e4aab2d46525e3d0c306503b7a00c9d25c1646e9d7462182682a58947c7435864af805a3b6f85906d8b21e5675cc8383cb
 DIST tdesktop-2.1.0-full.tar.gz 26133964 BLAKE2B c5eb476ea3ed02c2618e5b770bdce365bcf0d6124f75558570189e07e9dcd9f6f3282d53fec621be736cbd1269a9dd820629d4d9a36167d8f71109bfcd5a52e2 SHA512 46f5453c64d1dbd4cf8adde73fcc48e6b6f795972ab0f6516cb55112f47d5af990a049da356bedb81e6d3f7103c14a7be45369ff9a5a1812c07a1bfcda70646d
diff --git a/net-im/telegram-desktop/files/1.9.21-icon.patch b/net-im/telegram-desktop/files/1.9.21-icon.patch
deleted file mode 100644 (file)
index 689e01a..0000000
+++ /dev/null
@@ -1,99 +0,0 @@
-From d2291f5b17e0c169083a34e51053a99546207ec8 Mon Sep 17 00:00:00 2001
-From: Ilya Fedin <fedin-ilja2010@ya.ru>
-Date: Tue, 17 Mar 2020 23:13:11 +0400
-Subject: [PATCH] Fix panel icon forcing
-
----
- .../platform/linux/main_window_linux.cpp      | 20 +++++++++++--------
- .../platform/linux/main_window_linux.h        |  2 +-
- 2 files changed, 13 insertions(+), 9 deletions(-)
-
-diff --git a/Telegram/SourceFiles/platform/linux/main_window_linux.cpp b/Telegram/SourceFiles/platform/linux/main_window_linux.cpp
-index 347395ab38..3d30ef755c 100644
---- a/Telegram/SourceFiles/platform/linux/main_window_linux.cpp
-+++ b/Telegram/SourceFiles/platform/linux/main_window_linux.cpp
-@@ -78,7 +78,8 @@ QString GetTrayIconName(int counter, bool muted) {
-       const auto iconName = GetIconName();
-       const auto panelIconName = GetPanelIconName(counter, muted);
--      if (QIcon::hasThemeIcon(panelIconName)) {
-+      if (QIcon::hasThemeIcon(panelIconName)
-+              || qEnvironmentVariableIsSet(kForcePanelIcon.utf8())) {
-               return panelIconName;
-       } else if (QIcon::hasThemeIcon(iconName)) {
-               return iconName;
-@@ -158,7 +159,7 @@ QIcon TrayIconGen(int counter, bool muted) {
-                       || iconThemeName != TrayIconThemeName
-                       || iconName != TrayIconName) {
-                       if (!iconName.isEmpty()) {
--                              if(systemIcon.isNull()) {
-+                              if (systemIcon.isNull()) {
-                                       systemIcon = QIcon::fromTheme(iconName);
-                               }
-@@ -467,11 +468,12 @@ void MainWindow::psTrayMenuUpdated() {
- }
- #ifndef TDESKTOP_DISABLE_DBUS_INTEGRATION
--void MainWindow::setSNITrayIcon(int counter, bool muted, bool firstShow) {
-+void MainWindow::setSNITrayIcon(int counter, bool muted) {
-       const auto iconName = GetTrayIconName(counter, muted);
-       if (qEnvironmentVariableIsSet(kDisableTrayCounter.utf8())
--              && ((!iconName.isEmpty() && !InSnap())
-+              && !iconName.isEmpty()
-+              && (!InSnap()
-                       || qEnvironmentVariableIsSet(kForcePanelIcon.utf8()))) {
-               if (_sniTrayIcon->iconName() == iconName) {
-                       return;
-@@ -480,7 +482,8 @@ void MainWindow::setSNITrayIcon(int counter, bool muted, bool firstShow) {
-               _sniTrayIcon->setIconByName(iconName);
-               _sniTrayIcon->setToolTipIconByName(iconName);
-       } else if (IsIndicatorApplication()) {
--              if(!IsIconRegenerationNeeded(counter, muted) && !firstShow) {
-+              if (!IsIconRegenerationNeeded(counter, muted)
-+                      && !_sniTrayIcon->iconName().isEmpty()) {
-                       return;
-               }
-@@ -492,7 +495,8 @@ void MainWindow::setSNITrayIcon(int counter, bool muted, bool firstShow) {
-                       _sniTrayIcon->setIconByName(_trayIconFile->fileName());
-               }
-       } else {
--              if(!IsIconRegenerationNeeded(counter, muted) && !firstShow) {
-+              if (!IsIconRegenerationNeeded(counter, muted)
-+                      && !_sniTrayIcon->iconPixmap().isEmpty()) {
-                       return;
-               }
-@@ -554,7 +558,7 @@ void MainWindow::onSNIOwnerChanged(
-       cSetSupportTray(trayAvailable);
--      if(cSupportTray()) {
-+      if (cSupportTray()) {
-               psSetupTrayIcon();
-       } else {
-               LOG(("System tray is not available."));
-@@ -575,7 +579,7 @@ void MainWindow::psSetupTrayIcon() {
-                               this);
-                       _sniTrayIcon->setTitle(AppName.utf16());
--                      setSNITrayIcon(counter, muted, true);
-+                      setSNITrayIcon(counter, muted);
-                       attachToSNITrayIcon();
-               }
-diff --git a/Telegram/SourceFiles/platform/linux/main_window_linux.h b/Telegram/SourceFiles/platform/linux/main_window_linux.h
-index 8602c53806..43ab722845 100644
---- a/Telegram/SourceFiles/platform/linux/main_window_linux.h
-+++ b/Telegram/SourceFiles/platform/linux/main_window_linux.h
-@@ -123,7 +123,7 @@ public slots:
-       QAction *psMonospace = nullptr;
-       QAction *psClearFormat = nullptr;
--      void setSNITrayIcon(int counter, bool muted, bool firstShow = false);
-+      void setSNITrayIcon(int counter, bool muted);
-       void attachToSNITrayIcon();
- #endif // !TDESKTOP_DISABLE_DBUS_INTEGRATION
diff --git a/net-im/telegram-desktop/telegram-desktop-1.9.21.ebuild b/net-im/telegram-desktop/telegram-desktop-1.9.21.ebuild
deleted file mode 100644 (file)
index 653b2ea..0000000
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit cmake desktop flag-o-matic python-any-r1 xdg-utils
-
-MY_P="tdesktop-${PV}-full"
-
-DESCRIPTION="Official desktop client for Telegram"
-HOMEPAGE="https://desktop.telegram.org"
-SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
-
-LICENSE="GPL-3-with-openssl-exception"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64"
-IUSE="+alsa +dbus enchant +hunspell libressl pulseaudio +spell"
-
-RDEPEND="
-       !net-im/telegram-desktop-bin
-       app-arch/lz4:=
-       app-arch/xz-utils
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       >=dev-cpp/ms-gsl-2.1.0
-       dev-cpp/range-v3
-       dev-libs/xxhash
-       dev-qt/qtcore:5
-       dev-qt/qtimageformats:5
-       dev-qt/qtnetwork:5
-       dev-qt/qtsvg:5
-       media-libs/fontconfig:=
-       >=media-libs/libtgvoip-2.4.4_p20200301[alsa?,pulseaudio?]
-       media-libs/openal[alsa?,pulseaudio?]
-       media-libs/opus:=
-       media-video/ffmpeg:=[opus]
-       sys-libs/zlib[minizip]
-       virtual/libiconv
-       x11-libs/libva:=[X,drm]
-       x11-libs/libX11
-       || (
-               dev-qt/qtgui:5[jpeg,png,X(-)]
-               dev-qt/qtgui:5[jpeg,png,xcb(-)]
-       )
-       || (
-               dev-qt/qtwidgets:5[png,X(-)]
-               dev-qt/qtwidgets:5[png,xcb(-)]
-       )
-       dbus? (
-               dev-qt/qtdbus:5
-               dev-libs/libdbusmenu-qt[qt5(+)]
-       )
-       enchant? ( app-text/enchant:= )
-       hunspell? ( >=app-text/hunspell-1.7:= )
-       pulseaudio? ( media-sound/pulseaudio )
-"
-
-DEPEND="
-       ${PYTHON_DEPS}
-       ${RDEPEND}
-"
-
-BDEPEND="
-       >=dev-util/cmake-3.16
-       virtual/pkgconfig
-"
-
-REQUIRED_USE="|| ( alsa pulseaudio )
-       spell? (
-               ^^ ( enchant hunspell )
-       )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
-       "${FILESDIR}/1.9.21-icon.patch"
-)
-
-src_configure() {
-       local mycxxflags=(
-               -Wno-deprecated-declarations
-               -Wno-error=deprecated-declarations
-               -Wno-switch
-       )
-
-       append-cxxflags "${mycxxflags[@]}"
-
-       # TODO: unbundle header-only libs, ofc telegram uses git versions...
-       # it fals with tl-expected-1.0.0, so we use bundled for now to avoid git rev snapshots
-       # EXPECTED VARIANT
-       local mycmakeargs=(
-               -DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON
-               -DDESKTOP_APP_USE_GLIBC_WRAPS=OFF
-               -DDESKTOP_APP_USE_PACKAGED=ON
-               -DDESKTOP_APP_USE_PACKAGED_EXPECTED=OFF
-               -DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF
-               -DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF
-               -DTDESKTOP_LAUNCHER_BASENAME="${PN}"
-               -DDESKTOP_APP_DISABLE_DBUS_INTEGRATION="$(usex dbus OFF ON)"
-               -DDESKTOP_APP_DISABLE_SPELLCHECK="$(usex spell OFF ON)" # enables hunspell
-               -DDESKTOP_APP_USE_ENCHANT="$(usex enchant ON OFF)" # enables enchant and disables hunspell
-       )
-
-       if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
-               einfo "Found custom API credentials"
-               mycmakeargs+=(
-                       -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
-                       -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
-               )
-       else
-               # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
-               # Building with snapcraft API credentials by default
-               # Custom API credentials can be obtained here:
-               # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
-               # After getting credentials you can export variables:
-               #  export MY_TDESKTOP_API_ID="17349""
-               #  export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
-               # and restart the build"
-               # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
-               # portage will use custom variable every build automatically
-               mycmakeargs+=(
-                       -DTDESKTOP_API_ID="611335"
-                       -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
-               )
-       fi
-
-       cmake_src_configure
-}
-
-pkg_postinst() {
-       xdg_desktop_database_update
-       xdg_icon_cache_update
-       xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
-       xdg_desktop_database_update
-       xdg_icon_cache_update
-       xdg_mimeinfo_database_update
-}