dev-util/cmake: use correct pattern to undo cmake eclass modifications
authorRolf Eike Beer <eike@sf-mail.de>
Wed, 3 Jul 2019 20:35:08 +0000 (22:35 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 4 Jul 2019 19:36:07 +0000 (21:36 +0200)
Fixes: 6b7998b644e6f4469a7cb4c64776013a74363866
Closes: https://bugs.gentoo.org/686266
Closes: https://github.com/gentoo/gentoo/pull/12385
Signed-off-by: Rolf Eike Beer <eike@sf-mail.de>
Closes: https://github.com/gentoo/gentoo/pull/12385
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-util/cmake/cmake-3.14.3.ebuild
dev-util/cmake/cmake-3.14.5.ebuild
dev-util/cmake/cmake-3.15.0_rc3.ebuild

index 42fd589bd81b45e2a8904098ee6df53b9449df2a..40c7542127452d1c39c4e8ad012b44b55e908b1a 100644 (file)
@@ -101,7 +101,7 @@ cmake_src_bootstrap() {
 cmake_src_test() {
        # fix OutDir and SelectLibraryConfigurations tests
        # these are altered thanks to our eclass
-       sed -i -e 's:#IGNORE ::g' \
+       sed -i -e 's:^#_cmake_modify_IGNORE ::g' \
                "${S}"/Tests/{OutDir,CMakeOnly/SelectLibraryConfigurations}/CMakeLists.txt \
                || die
 
index 0ec739545d3b73ec12747682410329e20afaca18..e3507ad6196d4a2f7c91f5e8ded2db8b77fffd62 100644 (file)
@@ -101,7 +101,7 @@ cmake_src_bootstrap() {
 cmake_src_test() {
        # fix OutDir and SelectLibraryConfigurations tests
        # these are altered thanks to our eclass
-       sed -i -e 's:#IGNORE ::g' \
+       sed -i -e 's:^#_cmake_modify_IGNORE ::g' \
                "${S}"/Tests/{OutDir,CMakeOnly/SelectLibraryConfigurations}/CMakeLists.txt \
                || die
 
index b8f071ece70aa9952038e2ae30a754f1a8b2a169..0fb93b78d73ff9599863c775ec55bb5780514e57 100644 (file)
@@ -101,7 +101,7 @@ cmake_src_bootstrap() {
 cmake_src_test() {
        # fix OutDir and SelectLibraryConfigurations tests
        # these are altered thanks to our eclass
-       sed -i -e 's:#IGNORE ::g' \
+       sed -i -e 's:^#_cmake_modify_IGNORE ::g' \
                "${S}"/Tests/{OutDir,CMakeOnly/SelectLibraryConfigurations}/CMakeLists.txt \
                || die