mail-filter/postfwd: added v2.02, remove v2.00
authorMarc Schiffbauer <mschiff@gentoo.org>
Mon, 8 Jul 2019 11:43:33 +0000 (13:43 +0200)
committerMarc Schiffbauer <mschiff@gentoo.org>
Mon, 8 Jul 2019 11:51:16 +0000 (13:51 +0200)
Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

mail-filter/postfwd/Manifest
mail-filter/postfwd/postfwd-2.02.ebuild [moved from mail-filter/postfwd/postfwd-2.00.ebuild with 63% similarity]

index 28c0ed381dafd496a48df4a5b351f48a6c7539ee..7290afea910af15930d43b2c9d6ce936c746fcc6 100644 (file)
@@ -1,2 +1,3 @@
 DIST postfwd-1.35.tar.gz 354609 BLAKE2B 8e85db37d7f81be4613d9c2e411760af48650125af7b22439e3b47a8c3c7285564bfcd7a9fe4eed35d2603ddf80dcdf11d75f84afcaf3e57d53c4e986068f06c SHA512 7b0e8c8a755f085c108c45b28ec8c32139581ce129d0b8586f1876ae87f134a4fb1606d45105ccfa62351ca2d3b87f001ea52aacab0680f3345c41562bec5207
 DIST postfwd-2.00.tar.gz 265346 BLAKE2B ec67bffb5f6959e9516965516688e72f337f717a3159a094dc0373331a5fc09a451f664643a7f3e739b28d4137c130acfb39129b8557b4d41f4d445679f52623 SHA512 b9994b7dd96f1460d66ef35f173c5a4a4d72beb5b955092349304eae2672182874f07236fe5512ba3d0ecc68e2f0472e76b3667ded011536b0cf6f2d874bb039
+DIST postfwd-2.02.tar.gz 265781 BLAKE2B de63bdab4f7c1b117a16ebed2248f1e89b7c973bb34cee1b3fbbceda8c9d9b92d180fb5de8a332732b69a05d1b157be1c95d81ded003641d78665064a4881432 SHA512 23b48ca7218fba46f4b1887c4c6724112866c2e22e56f749602ba74430c4cf4c8418b9effb400ea4a468a5f137c764cac9611879e37d1585cf6d0b31dd41060f
similarity index 63%
rename from mail-filter/postfwd/postfwd-2.00.ebuild
rename to mail-filter/postfwd/postfwd-2.02.ebuild
index f4ce5c30fd1586e0b0f8bcb59465d048f3b5256e..df52b4a6f0524f9742a04d753fc61ed2759ddff6 100644 (file)
@@ -1,18 +1,17 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit eutils user systemd
+inherit systemd user
 
 DESCRIPTION="Versatile Postfix policy server with a flexible ruleset based configuration"
-HOMEPAGE="http://www.postfwd.org/"
-SRC_URI="http://www.postfwd.org/${P}.tar.gz"
+HOMEPAGE="https://www.postfwd.org/"
+SRC_URI="https://www.postfwd.org/${P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="+tools"
 
 DEPEND=""
 RDEPEND=">=dev-lang/perl-5.16.3
@@ -35,27 +34,21 @@ pkg_setup() {
 
 src_install() {
        local BIN="postfwd3"
-       # programs and tools
-       dosbin "${S}"/sbin/${BIN}
+       # program
+       dosbin sbin/${BIN}
 
        # man pages and documentation
-       doman "${S}"/man/man8/${BIN}.8
-       dodoc "${S}"/doc/{${BIN}.CHANGELOG,${BIN}.txt}
+       doman man/man8/${BIN}.8
+       dodoc doc/{${BIN}.CHANGELOG,${BIN}.txt}
 
-       # example configuration(s)
-       insinto /usr/share/doc/${PF}/examples
-       newins "${S}"/etc/${PN}.cf.sample ${PN}.cf.dist
+       # example configuration
+       dodoc etc/${PN}.cf.sample
 
-       # plugins
-       dodoc -r "${S}"/plugins
-
-       # tools
-       if use tools; then
-               dodoc -r "${S}"/tools
-       fi
+       # plugins and tools
+       dodoc -r plugins tools
 
        # start scripts script and respective configuration file
-       newinitd "${FILESDIR}"/${PN}.init.3 ${PN}
+       newinitd "${FILESDIR}"/${PN}.init.3-r1 ${PN}
        newconfd "${FILESDIR}"/${PN}.conf.3 ${PN}
        systemd_newunit "${FILESDIR}"/${PN}.service.3 ${PN}.service
 }
@@ -65,33 +58,30 @@ pkg_postinst() {
        einfo "${PN} has no default configuration for safety reasons. Every"
        einfo "mail system is different, so you should craft a set of rules"
        einfo "that is suitable for your environment and save it to:"
-       einfo "   /etc/postfwd.cf"
-       einfo "You can find example configurations in:"
-       einfo "   /usr/share/doc/${PF}/examples"
+       einfo "   ${EROOT}/etc/postfwd.cf"
+       einfo "You can find a sample configuration in:"
+       einfo "   ${EROOT}/usr/share/doc/${PF}"
        einfo
        einfo "If you want ${PN} to start on system boot, you have to add it your"
        einfo "default run level if using OpenRC:"
        einfo "   # rc-update add postfwd default"
-       einfo "Also remember to edit /etc/conf.d/${PN} to your liking."A
+       einfo "Also remember to edit ${EROOT}/etc/conf.d/${PN} to your liking."
        einfo
        einfo "Or - if you are using systemd - enable the service:"
        einfo "   # systemctl enable postfwd"
        einfo
        einfo "A plugins sample folder has been placed under:"
        einfo
-       einfo "   /usr/share/doc/${PF}/plugins"
-
-       if use tools; then
-               einfo
-               einfo "You can find additional tools for testing ${PN} in:"
-               einfo "   /usr/share/doc/${PF}/tools"
-       fi
+       einfo "   ${EROOT}/usr/share/doc/${PF}/plugins"
+       einfo
+       einfo "You can find additional tools for testing ${PN} in:"
+       einfo "   ${EROOT}/usr/share/doc/${PF}/tools"
 
        ewarn
        ewarn "Please read the documentation carefully and properly test new"
        ewarn "rulesets before putting them into production use. Otherwise you"
        ewarn "risk accidental mail loss or worse."
        ewarn
-       ewarn "Visit http://www.postfwd.org/ for more information."
+       ewarn "Visit https://www.postfwd.org/ for more information."
        ewarn
 }