Add debug version and standalone player, thanks to Jakub, closes bug #162600
authorOlivier Crête <tester@gentoo.org>
Fri, 19 Jan 2007 14:58:47 +0000 (14:58 +0000)
committerOlivier Crête <tester@gentoo.org>
Fri, 19 Jan 2007 14:58:47 +0000 (14:58 +0000)
Package-Manager: portage-2.1.1-r2

net-www/netscape-flash/ChangeLog
net-www/netscape-flash/files/digest-netscape-flash-9.0.31.0
net-www/netscape-flash/netscape-flash-9.0.31.0.ebuild

index 2e0be5a13827ed4416a6349b7c0807298e18de6b..eb1f104c9039f7e984d33101ca7f27e9f38c1aa7 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for net-www/netscape-flash
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.47 2007/01/17 20:14:24 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.48 2007/01/19 14:58:47 tester Exp $
+
+  19 Jan 2007; Olivier Crête <tester@gentoo.org>
+  -netscape-flash-9.0.21.78.ebuild, netscape-flash-9.0.31.0.ebuild:
+  Add debug version and standalone player, thanks to Jakub, closes bug #162600
 
   17 Jan 2007; Alec Warner <antarus@gentoo.org>
   netscape-flash-7.0.68.ebuild, netscape-flash-9.0.21.78.ebuild,
index 93177ed6e42a5532d2d131a17bee05bf4e0bb5a5..01d1d9b9fb348955bd1c9dc1943a20b6028979ad 100644 (file)
@@ -1,3 +1,6 @@
+MD5 4536166e1fa645d0ade0286b1a9288d9 flash_player_9_linux_dev.tar.gz 8820435
+RMD160 4bd1348672a31c276aaa3b043f9d25ab8ac127e6 flash_player_9_linux_dev.tar.gz 8820435
+SHA256 e51c56a46149738b6dd445bf6b1f0926652e0b1476c527f665543d3d2e833d97 flash_player_9_linux_dev.tar.gz 8820435
 MD5 76b38231a68995935185aa42dfda9db7 install_flash_player_9_linux.tar.gz 2609703
 RMD160 bad57e9349c5b1bb0b12a7dee7dea8f24af2f764 install_flash_player_9_linux.tar.gz 2609703
 SHA256 e31b971be7f98ea7eff67b2783ae20170c4d9f595b43ae5b59f98385a2b0c978 install_flash_player_9_linux.tar.gz 2609703
index 1bdf8daf66829618e749db20cc5845c8831adf08..74d6cb08bbe77b3b8babd9328ff179b84b4d838e 100644 (file)
@@ -1,13 +1,17 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-9.0.31.0.ebuild,v 1.2 2007/01/17 20:14:24 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-9.0.31.0.ebuild,v 1.3 2007/01/19 14:58:47 tester Exp $
 
 inherit nsplugins
 
+MY_P="install_flash_player_9_linux"
+MY_PD="flash_player_9_linux_dev"
+
 DESCRIPTION="Adobe Flash Player"
-SRC_URI="http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz"
+SRC_URI="!debug? ( http://fpdownload.macromedia.com/get/flashplayer/current/${MY_P}.tar.gz )
+       http://fpdownload.macromedia.com/pub/flashplayer/updaters/9/${MY_PD}.tar.gz"
 HOMEPAGE="http://www.adobe.com/"
-IUSE=""
+IUSE="debug"
 SLOT="0"
 
 KEYWORDS="-* ~amd64 ~x86"
@@ -15,6 +19,8 @@ LICENSE="AdobeFlash-9.0.31.0"
 S=${WORKDIR}/install_flash_player_9_linux
 RESTRICT="strip mirror"
 
+S=${WORKDIR}
+
 DEPEND="!net-www/gplflash
        amd64? ( app-emulation/emul-linux-x86-baselibs
                        app-emulation/emul-linux-x86-gtklibs
@@ -35,8 +41,25 @@ pkg_setup() {
        has_multilib_profile && ABI="x86"
 }
 
+src_unpack() {
+       unpack ${A}
+
+       cd ${S} 
+       if use debug; then
+               unpack ./${MY_PD}/plugin/debugger/${MY_P}.tar.gz
+               unpack ./${MY_PD}/standalone/debugger/flashplayer.tar.gz
+       else
+               unpack ./${MY_PD}/standalone/release/flashplayer.tar.gz
+       fi
+}
+
 src_install() {
+       dobin flashplayer
 
+       dodoc ${MY_PD}/README
+       use debug || dodoc ${MY_P}/Readme.txt
+       
+       cd ${MY_P}
        exeinto /opt/netscape/plugins
        doexe libflashplayer.so
        insinto /opt/netscape/plugins
@@ -44,6 +67,4 @@ src_install() {
 
        inst_plugin /opt/netscape/plugins/libflashplayer.so
        inst_plugin /opt/netscape/plugins/flashplayer.xpt
-
-       dodoc Readme.txt
 }