dev-vcs/subversion: fix test wc-queries-test test
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 24 Jan 2019 19:13:11 +0000 (20:13 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 24 Jan 2019 19:13:11 +0000 (20:13 +0100)
Thanks to Branko Čibej (upstream) for the patch!

Closes: https://bugs.gentoo.org/605438
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-vcs/subversion/files/subversion-1.9.7-fix-wc-queries-test-test.patch [new file with mode: 0644]
dev-vcs/subversion/subversion-1.10.3.ebuild
dev-vcs/subversion/subversion-1.10.4.ebuild
dev-vcs/subversion/subversion-1.11.0.ebuild
dev-vcs/subversion/subversion-1.11.1.ebuild
dev-vcs/subversion/subversion-1.9.7-r1.ebuild

diff --git a/dev-vcs/subversion/files/subversion-1.9.7-fix-wc-queries-test-test.patch b/dev-vcs/subversion/files/subversion-1.9.7-fix-wc-queries-test-test.patch
new file mode 100644 (file)
index 0000000..6658bd6
--- /dev/null
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/605438
+
+--- a/subversion/tests/libsvn_wc/wc-queries-test.c     2019/01/24 10:33:42     1852012
++++ b/subversion/tests/libsvn_wc/wc-queries-test.c     2019/01/24 10:58:23     1852013
+@@ -670,7 +670,20 @@
+                        || (item->expression_vars < 1))
+                    && !is_result_table(item->table))
+             {
+-              if (in_list(primary_key_statements, i))
++              if (MATCH_TOKEN(item->table, "sqlite_master"))
++                {
++                  /* The sqlite_master table does not have an index.
++                     Query explanations that say 'SCAN TABLE sqlite_master'
++                     will appear if SQLite was compiled with the option
++                     SQLITE_ENABLE_STMT_SCANSTATUS, for queries such
++                     as 'DROP TABLE foo', but the performance of such
++                     statements is not our concern here. */
++
++                  /* "Slow" statements do expect too see a warning, however. */
++                  if (is_slow_statement(i))
++                    warned = TRUE;
++                }
++              else if (in_list(primary_key_statements, i))
+                 {
+                   /* Reported as primary key index usage in Sqlite 3.7,
+                      as table scan in 3.8+, while the execution plan is
index 633b624d55488270a6f8aadd462566701f2c1e10..b13dd328ecf91c5cb6a2686075224763add61493 100644 (file)
@@ -151,6 +151,7 @@ pkg_setup() {
 
 src_prepare() {
        eapply "${WORKDIR}/patches"
+       eapply "${FILESDIR}"/${PN}-1.9.7-fix-wc-queries-test-test.patch
        eapply_user
 
        fperms +x build/transform_libtool_scripts.sh
index e21f5be59ff309072fdd2fb11d3c45b2958dd951..ef55999b2c52a33a41dc7766cd39a5184ab8efda 100644 (file)
@@ -151,6 +151,7 @@ pkg_setup() {
 
 src_prepare() {
        eapply "${WORKDIR}/patches"
+       eapply "${FILESDIR}"/${PN}-1.9.7-fix-wc-queries-test-test.patch
        eapply_user
 
        fperms +x build/transform_libtool_scripts.sh
index df2a5c65a4c6eb88ae9f8962c2f15c5116b6b65b..a4a22eed9157338b7744146703a77b5da1f9f44a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -151,6 +151,7 @@ pkg_setup() {
 
 src_prepare() {
        eapply "${WORKDIR}/patches"
+       eapply "${FILESDIR}"/${PN}-1.9.7-fix-wc-queries-test-test.patch
        eapply_user
 
        fperms +x build/transform_libtool_scripts.sh
index 5b17d2b2a8c6a33b84efb263f0d94e027152b6cc..a4a22eed9157338b7744146703a77b5da1f9f44a 100644 (file)
@@ -151,6 +151,7 @@ pkg_setup() {
 
 src_prepare() {
        eapply "${WORKDIR}/patches"
+       eapply "${FILESDIR}"/${PN}-1.9.7-fix-wc-queries-test-test.patch
        eapply_user
 
        fperms +x build/transform_libtool_scripts.sh
index c135b20995f5c59b93ad0991001cf82a5ada8c86..b9444c0aaa8964dec169a6195e8008aca0f4172b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -88,6 +88,7 @@ PATCHES=(
        "${WORKDIR}"/${PN}-1.8.18-patchset/${PN}-1.8.1-revert_bdb6check.patch
        "${WORKDIR}"/${PN}-1.8.18-patchset/${PN}-1.8.16-javadoc-nolint.patch
        "${FILESDIR}"/${P}-kf5.patch
+       "${FILESDIR}"/${PN}-1.9.7-fix-wc-queries-test-test.patch
 )
 
 want_apache