games-emulation/dosbox-staging: initial import
authorBernard Cafarelli <voyageur@gentoo.org>
Sat, 9 May 2020 15:38:33 +0000 (17:38 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Sat, 9 May 2020 15:38:55 +0000 (17:38 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
games-emulation/dosbox-staging/Manifest [new file with mode: 0644]
games-emulation/dosbox-staging/dosbox-staging-0.75.0.ebuild [new file with mode: 0644]
games-emulation/dosbox-staging/metadata.xml [new file with mode: 0644]

diff --git a/games-emulation/dosbox-staging/Manifest b/games-emulation/dosbox-staging/Manifest
new file mode 100644 (file)
index 0000000..099aa87
--- /dev/null
@@ -0,0 +1 @@
+DIST dosbox-staging-0.75.0.tar.gz 1805354 BLAKE2B e376006a2c3890d98efdaa8041634bfca8b95f6c6471f36f8fdd53e319aad8d37f20bd195a20264bade1e6974327f1f888dec6050da493fc8a6e6bb6c5739150 SHA512 2e049ed44928ad4adeaca73d328cf8f415bcb8c1a399306b1e8a5fd2b7cd7c3d3fe10017b47e5d2f3e54c34042ee901b98486f5b47a3d2eaf43f4e13891f8b70
diff --git a/games-emulation/dosbox-staging/dosbox-staging-0.75.0.ebuild b/games-emulation/dosbox-staging/dosbox-staging-0.75.0.ebuild
new file mode 100644 (file)
index 0000000..fb71bde
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools desktop
+
+DESCRIPTION="Modernized DOSBox soft-fork"
+HOMEPAGE="https://dosbox-staging.github.io/"
+SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug dynrec opengl opus"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+       debug? ( sys-libs/ncurses:0= )
+       opengl? ( virtual/opengl )
+       opus? ( media-libs/opus )
+       media-libs/libpng:0=
+       media-libs/libsdl2[joystick,opengl?,video,X]
+       media-libs/sdl-net
+       sys-libs/zlib
+       !games-emulation/dosbox"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_enable alsa alsa-midi) \
+               $(use_enable debug) \
+               $(use_enable !dynrec dynamic-x86) \
+               $(use_enable dynrec) \
+               $(use_enable opengl) \
+               $(use_enable opus opus-cdda)
+}
+
+src_install() {
+       default
+       doicon contrib/icons/${PN}.svg
+       make_desktop_entry dosbox DOSBox-staging ${PN}.svg
+}
diff --git a/games-emulation/dosbox-staging/metadata.xml b/games-emulation/dosbox-staging/metadata.xml
new file mode 100644 (file)
index 0000000..ea78ea7
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>voyageur@gentoo.org</email>
+               <name>Bernard Cafarelli</name>
+       </maintainer>
+       <use>
+               <flag name="dynrec">Use recompiling cpu core instead of dynamic x86/x64 specific cpu core</flag>
+               <flag name="opus">Support compressed audio tracks (.opus) used with CDROM images</flag>
+       </use>
+       <upstream>
+               <remote-id type="github">dosbox-staging/dosbox-staging</remote-id>
+       </upstream>
+</pkgmetadata>