dev-ros/rosbag: use proper cryptodome import
authorAlexis Ballier <aballier@gentoo.org>
Wed, 13 May 2020 11:50:18 +0000 (13:50 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 13 May 2020 14:07:14 +0000 (16:07 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/rosbag/files/pycrypto.patch [new file with mode: 0644]
dev-ros/rosbag/rosbag-1.15.4.ebuild
dev-ros/rosbag/rosbag-9999.ebuild

diff --git a/dev-ros/rosbag/files/pycrypto.patch b/dev-ros/rosbag/files/pycrypto.patch
new file mode 100644 (file)
index 0000000..c221d1b
--- /dev/null
@@ -0,0 +1,15 @@
+Index: rosbag/src/rosbag/bag.py
+===================================================================
+--- rosbag.orig/src/rosbag/bag.py
++++ rosbag/src/rosbag/bag.py
+@@ -50,8 +50,8 @@ import threading
+ import time
+ import yaml
+-from Cryptodome.Cipher import AES
+-from Cryptodome.Random import get_random_bytes
++from Crypto.Cipher import AES
++from Crypto.Random import get_random_bytes
+ import gnupg
index 7d776ac0c2aa0e7d4b0342bc922a276d9e2dfbe8..8616e5bd170a910292e19c2801afb78f34e3d419 100644 (file)
@@ -34,3 +34,4 @@ RDEPEND="
 DEPEND="${RDEPEND}"
 RDEPEND="${RDEPEND}
        lz4? ( dev-ros/roslz4[${PYTHON_USEDEP}] )"
+PATCHES=( "${FILESDIR}/pycrypto.patch" )
index 7d776ac0c2aa0e7d4b0342bc922a276d9e2dfbe8..8616e5bd170a910292e19c2801afb78f34e3d419 100644 (file)
@@ -34,3 +34,4 @@ RDEPEND="
 DEPEND="${RDEPEND}"
 RDEPEND="${RDEPEND}
        lz4? ( dev-ros/roslz4[${PYTHON_USEDEP}] )"
+PATCHES=( "${FILESDIR}/pycrypto.patch" )