dev-games/cegui: Don't do Python things when USE=-python
authorJames Le Cuirot <chewi@gentoo.org>
Sat, 16 May 2020 19:54:18 +0000 (20:54 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 16 May 2020 20:43:17 +0000 (21:43 +0100)
Thanks to Samuel Bauer.

Closes: https://bugs.gentoo.org/710452
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
dev-games/cegui/cegui-0.8.7-r1.ebuild

index 64adf6bd13e712fec68cdf49eee7d493477b1db1..57181d880fda2ab2f93858b82fa3bcf1c82f5ed7 100644 (file)
@@ -16,7 +16,7 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="bidi debug devil doc freeimage expat irrlicht lua ogre opengl pcre python static-libs tinyxml truetype xerces-c +xml zip"
 REQUIRED_USE="|| ( expat tinyxml xerces-c xml )
-       ${PYTHON_REQUIRED_USE}" # bug 362223
+       python? ( ${PYTHON_REQUIRED_USE} )" # bug 362223
 
 # gles broken
 #      gles? ( media-libs/mesa[gles1] )
@@ -60,6 +60,10 @@ DEPEND="${RDEPEND}
 
 PATCHES=( "${FILESDIR}"/${P}-icu-59.patch )
 
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
 src_configure() {
        # http://www.cegui.org.uk/mantis/view.php?id=991
        append-ldflags $(no-as-needed)