dev-haskell/testpack: tweak for QuickCheck-2.8, bug #561010
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 21 Sep 2015 21:25:33 +0000 (22:25 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 21 Sep 2015 21:27:36 +0000 (22:27 +0100)
Reported-by: Toralf Förster
Bug: https://bugs.gentoo.org/561010

Package-Manager: portage-2.2.20

dev-haskell/testpack/files/testpack-2.1.3.0-HUnit-1.3.patch [new file with mode: 0644]
dev-haskell/testpack/files/testpack-2.1.3.0-qc28.patch
dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild

diff --git a/dev-haskell/testpack/files/testpack-2.1.3.0-HUnit-1.3.patch b/dev-haskell/testpack/files/testpack-2.1.3.0-HUnit-1.3.patch
new file mode 100644 (file)
index 0000000..599615a
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/src/Test/HUnit/Tools.hs b/src/Test/HUnit/Tools.hs
+index a24a510..6b8a25e 100644
+--- a/src/Test/HUnit/Tools.hs
++++ b/src/Test/HUnit/Tools.hs
+@@ -97,3 +97,7 @@ runVerbTestText (HU.PutText put us) t = do
+   reportFailure = reportProblem "Failure:" "Failure in: "
+-  reportProblem p0 p1 msg ss us = put line True us
++  reportProblem p0 p1
++#if MIN_VERSION_HUnit(1,3,0)
++                      _loc
++#endif
++                           msg ss us = put line True us
+    where line  = "### " ++ kind ++ path' ++ '\n' : msg
index 1bc9537f5d2a10723bb6a1c08c4ed3bac5b9634e..4ca1848888c6a67aadd9a9f26ec511c5c36b613d 100644 (file)
@@ -116,7 +116,7 @@ index 712c9bf..506686f 100644
 -                  reason = "Result: expected " ++ show expected ++ ", got " ++ show actual,
 -                  stamp = [], callbacks = []}
 -    
-+        P.result { P.ok = Just (expected == actual)
++        P.failed { P.ok = Just (expected == actual)
 +                 , P.reason = "Result: expected " ++ show expected ++ ", got " ++ show actual
 +                 }
  {- | Like '@=?', but with args in a different order. -}
index a3fa62e101e4aac371e676dc8e913b5a8ae69332..97ca628aef48dc27d39a832119ffaaf4364e892e 100644 (file)
@@ -30,4 +30,5 @@ DEPEND="${RDEPEND}
 
 src_prepare() {
        epatch "${FILESDIR}"/${P}-qc28.patch
+       epatch "${FILESDIR}"/${P}-HUnit-1.3.patch
 }