dev-ruby/trollop: add 2.9.10
authorHans de Graaff <graaff@gentoo.org>
Fri, 8 May 2020 05:22:17 +0000 (07:22 +0200)
committerHans de Graaff <graaff@gentoo.org>
Fri, 8 May 2020 05:42:33 +0000 (07:42 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/trollop/Manifest
dev-ruby/trollop/trollop-2.9.10.ebuild [new file with mode: 0644]

index 563a9380b8eb153b8b39905e550a51019f08e5a9..4bf1987e96a8609923ccb80539d96e0f52d4eee9 100644 (file)
@@ -1 +1,2 @@
 DIST trollop-2.1.3.gem 30208 BLAKE2B a5fd19679821c55459cf7792f3ec26b8580732e84107f7a3519dcbcf1729ce48567ca2d35346b3e27d3083a3b6cae160ded8c18a118cb04a7a6e60c82bd91e78 SHA512 4d172c6d75f40edb36c353d2e32afce10b012f02927772fa201256126f88c62adce39400225434a80fd678e1cad703e3d3f32cdeddd150287a44ff81a2fca819
+DIST trollop-2.9.10.gem 29696 BLAKE2B f69b1ab8ce166f9fe6198e177266ee86e38f3bed4c3a55529705aedc4518cc04a48b9bee4463887fc4ac1cd04cad98d35c298265ad1433ced11e0ff5bc1f50ce SHA512 21a0db09d480353ff846a1311b118e0b0db4ca13a559dd1749c1478eff7080dd04e5308dbf1807215eadb68e276c991970b23357e9a3497acb9f705f7f77253c
diff --git a/dev-ruby/trollop/trollop-2.9.10.ebuild b/dev-ruby/trollop/trollop-2.9.10.ebuild
new file mode 100644 (file)
index 0000000..5a12cb7
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="FAQ.txt History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Trollop is a commandline option parser for Ruby"
+HOMEPAGE="https://manageiq.github.io/trollop/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="2"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/chronic )"
+
+all_ruby_prepare() {
+       sed -i -e '/bundle/ s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+       MUTANT=true ${RUBY} -S rake test || die "Tests failed."
+}