dev-python/pypy: Update test failure list
authorMichał Górny <mgorny@gentoo.org>
Sun, 12 Apr 2020 17:17:27 +0000 (19:17 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 12 Apr 2020 17:47:14 +0000 (19:47 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pypy/pypy-7.3.1.ebuild

index e38b85a5caaadc51e718a39e9f8538a3c0ab13ad..1f32cc41d4b1a133fc0b0e9f84e62531a711be7b 100644 (file)
@@ -55,19 +55,14 @@ src_prepare() {
        # this test relies on pypy-c hardcoding correct build time paths
        sed -i -e 's:test_executable_without_cwd:_&:' \
                lib-python/2.7/test/test_subprocess.py || die
-       # this one seems to rely on cpython gc handling (?)
-       sed -i -e 's:test_number_of_objects:_&:' \
-               lib-python/2.7/test/test_multiprocessing.py || die
-       # hardcoded assumptions (?)
+       # broken upstream
+       # see http://buildbot.pypy.org/summary?branch=%3Ctrunk%3E
        sed -i -e 's:test_alpn_protocols:_&:' \
                -e 's:test_default_ecdh_curve:_&:' \
                lib-python/2.7/test/test_ssl.py || die
        # requires Internet
        sed -i -e '/class NetworkedTests/i@unittest.skip("Requires networking")' \
                lib-python/2.7/test/test_ssl.py || die
-       # TODO: investigate (sandbox?)
-       sed -i -e 's:test__copy_to_each:_&:' \
-               lib-python/2.7/test/test_pty.py || die
 
        eapply_user
 }