x11-misc/i855crt: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Tue, 24 Dec 2019 17:40:10 +0000 (18:40 +0100)
committerDavid Seifert <soap@gentoo.org>
Tue, 24 Dec 2019 17:40:10 +0000 (18:40 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
x11-misc/i855crt/files/i855crt-0.4-makefile.patch [new file with mode: 0644]
x11-misc/i855crt/i855crt-0.4-r1.ebuild

diff --git a/x11-misc/i855crt/files/i855crt-0.4-makefile.patch b/x11-misc/i855crt/files/i855crt-0.4-makefile.patch
new file mode 100644 (file)
index 0000000..e7deffb
--- /dev/null
@@ -0,0 +1,16 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,11 +1,6 @@
+-i855crt: i855crt.o vmodes.o
+-      gcc $(LDFLAGS) -o i855crt i855crt.o vmodes.o -L /usr/X11R6/lib -lXext -lXv
++LDLIBS = -lXv -lX11
+-i855crt.o: i855crt.c i855crt.h vmodes.h hw.h
+-      gcc $(CFLAGS) -c i855crt.c
+-
+-vmodes.o: vmodes.c vmodes.h
+-      gcc $(CFLAGS) -c vmodes.c
++i855crt: vmodes.o
+ clean:
+       rm *.o -f
index 1b8581227cd6a0ec88c039e016188cd0cbe22a22..25df8327c91c4acb1d098afa8160c5d12a12d38e 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
 
 DESCRIPTION="Intel Montara 855GM CRT out auxiliary driver"
 HOMEPAGE="http://i855crt.sourceforge.net/"
@@ -12,30 +12,31 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~x86"
-IUSE=""
 
-DEPEND="
+RDEPEND="
        x11-libs/libX11
-       x11-libs/libXv
-"
-RDEPEND="${DEPEND}"
+       x11-libs/libXv"
+DEPEND="${RDEPEND}"
 
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-i915support.diff
+PATCHES=(
+       "${FILESDIR}"/${PN}-i915support.diff
+       "${FILESDIR}"/${PN}-0.4-makefile.patch
+)
 
-       # respect CC, fix underlinking
-       sed -i Makefile \
-               -e 's|gcc|$(CC)|g;/LDFLAGS/{s|$| -lX11|g};s|-lXext||g' \
-               || die
-       export LIBS="-lX11"
-       tc-export CC
+src_prepare() {
+       default
 
        # upstream ships it with the binary, we want to make sure we compile it
        emake clean
 }
 
+src_configure() {
+       tc-export CC
+}
+
 src_install() {
        dobin i855crt
        insinto /etc
        doins i855crt.conf
+       einstalldocs
 }