dev-libs/libe: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sat, 14 Dec 2019 21:16:44 +0000 (22:16 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 14 Dec 2019 21:16:44 +0000 (22:16 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-libs/libe/files/libe-0.11.0-strtoul.patch [new file with mode: 0644]
dev-libs/libe/libe-0.11.0.ebuild

diff --git a/dev-libs/libe/files/libe-0.11.0-strtoul.patch b/dev-libs/libe/files/libe-0.11.0-strtoul.patch
new file mode 100644 (file)
index 0000000..e993c59
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/e/convert.h
++++ b/e/convert.h
+@@ -58,7 +58,7 @@
+     errno = 0;
+ #ifdef _MSC_VER
+-    ret = _strtoui64(s.c_str(), &endptr, base);
++    ret = strtoul(s.c_str(), &endptr, base);
+ #else
+     ret = strtoull(s.c_str(), &endptr, base);
+ #endif
index be48fd2433c4d53812c05dff062d2d93d7b5c466..45011db722601e2bac4bfc4d11cad5c0c5199227 100644 (file)
@@ -1,27 +1,31 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-
-inherit eutils
-
-# bit messy at the moment, next release should fix it I hope
-RESTRICT="test"
+EAPI=7
 
 DESCRIPTION="Hyperdex libe support library"
-
 HOMEPAGE="http://hyperdex.org"
 SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
+
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64"
+# bit messy at the moment, next release should fix it I hope
+RESTRICT="test"
+
+RDEPEND="dev-libs/libpo6"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
 
-IUSE=""
+PATCHES=( "${FILESDIR}"/${PN}-0.11.0-strtoul.patch )
+
+src_configure() {
+       econf --disable-static
+}
 
-RDEPEND=">=dev-libs/libpo6-0.8.0"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
+src_install() {
+       default
 
-src_prepare() {
-       sed -i -e 's/_strtoui64/strtoul/' e/convert.h || die
+       # no static archives
+       find "${D}" -name '*.la' -delete || die
 }