games-emulation/generator: Drop old
authorPacho Ramos <pacho@gentoo.org>
Sun, 29 Apr 2018 09:43:02 +0000 (11:43 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sun, 29 Apr 2018 11:25:43 +0000 (13:25 +0200)
Package-Manager: Portage-2.3.31, Repoman-2.3.9

games-emulation/generator/generator-0.35_p4.ebuild [deleted file]

diff --git a/games-emulation/generator/generator-0.35_p4.ebuild b/games-emulation/generator/generator-0.35_p4.ebuild
deleted file mode 100644 (file)
index e77ec24..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils toolchain-funcs games
-
-MY_P=${PN}-${PV/_p/-cbiere-r}
-DESCRIPTION="Sega Genesis / Mega Drive emulator"
-HOMEPAGE="http://www.squish.net/generator/"
-SRC_URI="http://www.squish.net/generator/cbiere/generator/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+sdlaudio"
-
-DEPEND="virtual/jpeg:0
-       media-libs/libsdl[joystick,video]
-       sdlaudio? ( media-libs/libsdl[sound] )"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
-       epatch \
-               "${FILESDIR}"/${P}-configure.patch \
-               "${FILESDIR}"/${P}-underlink.patch
-
-       sed -i -e 's/@GTK_CFLAGS@//g' main/Makefile.am || die
-       eautoreconf
-}
-
-src_configure() {
-       egamesconf \
-               --with-cmz80 \
-               --with-sdl \
-               --without-tcltk \
-               --with-gcc=$(gcc-major-version) \
-               $(use_with sdlaudio sdl-audio)
-}
-
-src_compile() {
-       [[ -f Makefile ]] && emake clean
-       emake -j1
-}
-
-src_install() {
-       dogamesbin main/generator-sdl
-       dodoc AUTHORS ChangeLog NEWS README TODO docs/*
-       prepgamesdirs
-}