kde-apps/kpat: Fix build with Qt 5.11
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 17 Dec 2018 19:25:35 +0000 (20:25 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 17 Dec 2018 19:25:53 +0000 (20:25 +0100)
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
kde-apps/kpat/files/kpat-18.04.3-qt-5.11.patch [new file with mode: 0644]
kde-apps/kpat/kpat-18.04.3.ebuild

diff --git a/kde-apps/kpat/files/kpat-18.04.3-qt-5.11.patch b/kde-apps/kpat/files/kpat-18.04.3-qt-5.11.patch
new file mode 100644 (file)
index 0000000..d3c7b78
--- /dev/null
@@ -0,0 +1,23 @@
+From 7a69e3f4b15a902c4008a428d5fbf0335526f49b Mon Sep 17 00:00:00 2001
+From: Jonathan Marten <jjm@keelhaul.me.uk>
+Date: Sat, 22 Sep 2018 16:56:04 +0100
+Subject: Needs include of <QBuffer> for Qt 5.11
+
+---
+ mainwindow.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/mainwindow.cpp b/mainwindow.cpp
+index cec0685..a597717 100644
+--- a/mainwindow.cpp
++++ b/mainwindow.cpp
+@@ -78,6 +78,7 @@
+ #include <QList>
+ #include <QPointer>
+ #include <QTimer>
++#include <QBuffer>
+ #include <QXmlStreamReader>
+ #include <QDesktopWidget>
+ #include <QKeySequence>
+-- 
+cgit v1.1
index a023a866ad02fbdf4ca3436d70458eb9694a2e5a..f6681caac28b5dd7c35dbebb243ebcd39a1c0586 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -34,3 +34,5 @@ DEPEND="
        x11-misc/shared-mime-info
 "
 RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )