dev-php/sebastian-comparator: Version bump for 3.0.2
authorBrian Evans <grknight@gentoo.org>
Thu, 19 Dec 2019 21:23:05 +0000 (16:23 -0500)
committerBrian Evans <grknight@gentoo.org>
Thu, 19 Dec 2019 21:50:54 +0000 (16:50 -0500)
Signed-off-by: Brian Evans <grknight@gentoo.org>
dev-php/sebastian-comparator/Manifest
dev-php/sebastian-comparator/sebastian-comparator-3.0.2.ebuild [new file with mode: 0644]

index 570eec425f80000a01f019b8003240eb89d5dade..333288ad55d1ce80f32b316236b1ccd805f66325 100644 (file)
@@ -1 +1,2 @@
 DIST sebastian-comparator-1.2.4.tar.gz 13402 BLAKE2B 5fc664e42408a188ed8601f2413f0b6517e5fd9b26f85be3177f09d6aaf4fda8eaa2e9e643e08914fb18aca0c795989d1e341d28476e3857c7d991bd2c06d51c SHA512 b7ca4bbdd91c9d59f83c4ccbd63d7755205f6686de7d7e41808faba404df8f58173a0699a0e4d1fbc09914c2fcf841ddc4df41a86aa5cd0fdffa3be4d438a8aa
+DIST sebastian-comparator-3.0.2.tar.gz 16305 BLAKE2B 3cc8551fad28542823fba182abf6e9f33bafa0fea004ceee7d2b192f250678ec7f2014b7e9ae16eee1ec84ff37e656f5612a0d45d3bc10c5959831d39d851fee SHA512 05d5cdb5ce6346325c3f7c6f7b6669de7d599e0b65a95505a85aca887df5498d5baa22f22e9065bf185ac50df1abc969bf86263d31a3923034607938a5eace58
diff --git a/dev-php/sebastian-comparator/sebastian-comparator-3.0.2.ebuild b/dev-php/sebastian-comparator/sebastian-comparator-3.0.2.ebuild
new file mode 100644 (file)
index 0000000..cb5336b
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Compare PHP values for equality"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+       >=dev-php/sebastian-diff-3.0
+       <dev-php/sebastian-diff-4.0
+       >=dev-php/sebastian-exporter-3.1
+       <dev-php/sebastian-exporter-4.0
+       >=dev-lang/php-7.1:*
+"
+src_install() {
+       insinto /usr/share/php/SebastianBergmann/Comparator
+       doins -r src/*
+       doins "${FILESDIR}/autoload.php"
+}