games-board/sirius: Fix format-security. Bug #539102
authorTupone Alfredo <tupone@gentoo.org>
Thu, 14 Jan 2016 20:39:57 +0000 (21:39 +0100)
committerTupone Alfredo <tupone@gentoo.org>
Thu, 14 Jan 2016 20:40:33 +0000 (21:40 +0100)
Package-Manager: portage-2.2.26

games-board/sirius/files/sirius-0.8.0-format.patch [new file with mode: 0644]
games-board/sirius/sirius-0.8.0.ebuild

diff --git a/games-board/sirius/files/sirius-0.8.0-format.patch b/games-board/sirius/files/sirius-0.8.0-format.patch
new file mode 100644 (file)
index 0000000..dccf6e2
--- /dev/null
@@ -0,0 +1,11 @@
+--- src/sirius.c.old   2016-01-14 21:22:53.946900371 +0100
++++ src/sirius.c       2016-01-14 21:24:08.240507669 +0100
+@@ -180,7 +180,7 @@
+       paus = 1;
+-      box = gtk_message_dialog_new (GTK_WINDOW (window), GTK_DIALOG_MODAL, GTK_MESSAGE_INFO, GTK_BUTTONS_OK, message);
++      box = gtk_message_dialog_new (GTK_WINDOW (window), GTK_DIALOG_MODAL, GTK_MESSAGE_INFO, GTK_BUTTONS_OK, "%s", message);
+       gtk_dialog_run (GTK_DIALOG(box));
+       gtk_widget_destroy(box);
index 1396a940df92fe02edadbb6111553d323d48eb81..cccde9906ce994d3379b8436c28d5308ba95665f 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
-inherit autotools games
+inherit autotools eutils games
 
 DESCRIPTION="A program for playing the game of othello/reversi"
 HOMEPAGE="http://sirius.bitvis.nu/"
@@ -29,6 +29,7 @@ src_prepare() {
                -e '/Categories/s/Application;//' \
                sirius.desktop.in || die
        mv configure.in configure.ac || die
+       epatch "${FILESDIR}"/${P}-format.patch
        eautoreconf
 }