dev-ml/flow_parser: Initial import.
authorAlexis Ballier <aballier@gentoo.org>
Mon, 3 Apr 2017 09:22:36 +0000 (11:22 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 3 Apr 2017 09:22:57 +0000 (11:22 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-ml/flow_parser/Manifest [new file with mode: 0644]
dev-ml/flow_parser/flow_parser-0.42.0.ebuild [new file with mode: 0644]
dev-ml/flow_parser/metadata.xml [new file with mode: 0644]

diff --git a/dev-ml/flow_parser/Manifest b/dev-ml/flow_parser/Manifest
new file mode 100644 (file)
index 0000000..a5358b6
--- /dev/null
@@ -0,0 +1 @@
+DIST flow-0.42.0.tar.gz 3202876 SHA256 5668a4a83242ac397239d001fbf071955a9e0a17ad255cb17b74345a434f7a93 SHA512 adcf4e2193eb1e2fcfea781efeac98abf3696d5684cb40224ff258d1246a2396649177ea77536c4c9ff5a610c4c7deea79305fe33157fb5e07b9c4c83a56600e WHIRLPOOL 58a2b392bc833c78b2690a75f6627f99082ae6f9e8405ef18421a50c2f531c4d3a009ae1740476c36863ffd8388b48aa9115fb1ea51971cbf36bf5d4f5b59ff0
diff --git a/dev-ml/flow_parser/flow_parser-0.42.0.ebuild b/dev-ml/flow_parser/flow_parser-0.42.0.ebuild
new file mode 100644 (file)
index 0000000..8460f51
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="JavaScript parser written in OCaml"
+HOMEPAGE="https://github.com/facebook/flow/tree/master/src/parser"
+SRC_URI="https://github.com/facebook/flow/archive/v${PV}.tar.gz -> flow-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-lang/ocaml:="
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+       dev-ml/ocamlbuild"
+
+S="${WORKDIR}/flow-${PV}/src/parser"
+
+src_compile() {
+       ocamlbuild parser_flow.cma parser_flow.cmxa || die
+}
+
+src_test() {
+       emake test-ocaml
+}
+
+src_install() {
+       findlib_src_preinst
+       emake ocamlfind-install
+       dodoc README.md
+}
diff --git a/dev-ml/flow_parser/metadata.xml b/dev-ml/flow_parser/metadata.xml
new file mode 100644 (file)
index 0000000..ffac4d7
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>ml@gentoo.org</email>
+       <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>