dev-python/nototools: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sun, 15 Sep 2019 12:06:21 +0000 (14:06 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sun, 15 Sep 2019 12:06:21 +0000 (14:06 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
dev-python/nototools/Manifest
dev-python/nototools/nototools-20190320.ebuild [new file with mode: 0644]

index d6f1c8d1bda226c8c547307ef9d318077709e34b..cd357b0463c8b92aa10112277a8a07aaf8df1969 100644 (file)
@@ -1 +1,2 @@
 DIST nototools-40aa4936022295cf851bb62f09a070f63fc8f5ae.tar.gz 9649749 BLAKE2B 5637373dfb70552f640b728814f3db1f3732b7335e7edac502a553a896e9715a8ef9356502c5d33a09a04ef45b0b27989f5a3602707964c7f91a1eee21e9112d SHA512 b1bfacc69f79b9ff7d40ff9b475a2e5808e57a66fa3bf2c79cdc56999e390cfdd2f92b71fd9e53e0e3571f30f3a54d1dcde2c3d8bf38378c72f79260d8d9d5ba
+DIST nototools-9c4375f07c9adc00c700c5d252df6a25d7425870.tar.gz 9693250 BLAKE2B 636832b538714d48aa78946b9af9985c55a5543828c3033b849fe3ad75c15472ea7515ca2a4a30c990457acdce2fcbad27d8e61fcd42a4bd7f009638f1bb4381 SHA512 dd2ffe072716c61c9eab9307308f6f72ca3a6631ec2402d03adc4e4483030d770035bf9b9ae66b5b580f1dd7e1cb546f03eff61c00c73069c804953587199e9e
diff --git a/dev-python/nototools/nototools-20190320.ebuild b/dev-python/nototools/nototools-20190320.ebuild
new file mode 100644 (file)
index 0000000..c669eea
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Doesn't work with python3 yet:
+# https://github.com/googlei18n/nototools/issues/472
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Noto fonts support tools and scripts plus web site generation"
+HOMEPAGE="https://github.com/googlei18n/nototools"
+
+COMMIT="9c4375f07c9adc00c700c5d252df6a25d7425870"
+SRC_URI="https://github.com/googlei18n/nototools/archive/${COMMIT}.tar.gz#/nototools-${COMMIT}.tar.gz"
+
+LICENSE="Apache-2.0 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+BDEPEND=""
+RDEPEND="${DEPEND}
+       media-gfx/scour
+       >=dev-python/booleanOperations-0.7.0[${PYTHON_USEDEP}]
+       >=dev-python/defcon-0.3.1[${PYTHON_USEDEP}]
+       >=dev-python/fonttools-3.36.0[${PYTHON_USEDEP}]
+       >=dev-python/pillow-4.0.0[${PYTHON_USEDEP}]
+       >=dev-python/pyclipper-1.0.6[${PYTHON_USEDEP}]
+       virtual/python-typing[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+python_test() {
+       esetup.py test
+}