net-dns/avahi: fix CVE-2017-6519 and CVE-2018-100084, bug #627020
authorAnthony G. Basile <blueness@gentoo.org>
Sat, 9 Nov 2019 16:44:22 +0000 (11:44 -0500)
committerAnthony G. Basile <blueness@gentoo.org>
Sat, 9 Nov 2019 16:44:22 +0000 (11:44 -0500)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
net-dns/avahi/avahi-0.7-r2.ebuild
net-dns/avahi/files/avahi-0.7-CVE-2017-6519.patch [new file with mode: 0644]

index 481ebbb78273f6df7ca00f3a2494b38bcad2eef2..bd5913ffa7940f4d1e52ed31a527b9849043be6a 100644 (file)
@@ -68,7 +68,10 @@ RDEPEND="
 
 MULTILIB_WRAPPED_HEADERS=( /usr/include/avahi-qt5/qt-watch.h )
 
-PATCHES=( "${FILESDIR}/${P}-qt5.patch" )
+PATCHES=(
+       "${FILESDIR}/${P}-qt5.patch"
+       "${FILESDIR}/${P}-CVE-2017-6519.patch"
+)
 
 pkg_preinst() {
        enewgroup netdev
diff --git a/net-dns/avahi/files/avahi-0.7-CVE-2017-6519.patch b/net-dns/avahi/files/avahi-0.7-CVE-2017-6519.patch
new file mode 100644 (file)
index 0000000..5fadfbc
--- /dev/null
@@ -0,0 +1,45 @@
+From e111def44a7df4624a4aa3f85fe98054bffb6b4f Mon Sep 17 00:00:00 2001
+From: Trent Lloyd <trent@lloyd.id.au>
+Date: Sat, 22 Dec 2018 09:06:07 +0800
+Subject: [PATCH] Drop legacy unicast queries from address not on local link
+
+When handling legacy unicast queries, ensure that the source IP is
+inside a subnet on the local link, otherwise drop the packet.
+
+Fixes #145
+Fixes #203
+CVE-2017-6519
+CVE-2018-100084
+---
+ avahi-core/server.c | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/avahi-core/server.c b/avahi-core/server.c
+index a2cb19a..a2580e3 100644
+--- a/avahi-core/server.c
++++ b/avahi-core/server.c
+@@ -930,6 +930,7 @@ static void dispatch_packet(AvahiServer *s, AvahiDnsPacket *p, const AvahiAddres
+     if (avahi_dns_packet_is_query(p)) {
+         int legacy_unicast = 0;
++        char t[AVAHI_ADDRESS_STR_MAX];
+         /* For queries EDNS0 might allow ARCOUNT != 0. We ignore the
+          * AR section completely here, so far. Until the day we add
+@@ -947,6 +948,13 @@ static void dispatch_packet(AvahiServer *s, AvahiDnsPacket *p, const AvahiAddres
+             legacy_unicast = 1;
+         }
++        if (!is_mdns_mcast_address(dst_address) &&
++            !avahi_interface_address_on_link(i, src_address)) {
++
++            avahi_log_debug("Received non-local unicast query from host %s on interface '%s.%i'.", avahi_address_snprint(t, sizeof(t), src_address), i->hardware->name, i->protocol);
++            return;
++        }
++
+         if (legacy_unicast)
+             reflect_legacy_unicast_query_packet(s, p, i, src_address, port);
+-- 
+2.21.0
+