work around parallel make issues - bug #561380
authorMichael Sterrett <mr_bones_@gentoo.org>
Mon, 5 Oct 2015 00:47:09 +0000 (20:47 -0400)
committerMichael Sterrett <mr_bones_@gentoo.org>
Mon, 5 Oct 2015 00:47:24 +0000 (20:47 -0400)
Package-Manager: portage-2.2.20.1

games-strategy/megaglest/megaglest-3.11.1.ebuild

index 3c74a8d381b99940e114baf3e06c1eccd13558f0..a0502649730ff66a9d71704c338fcf87005fe04c 100644 (file)
@@ -116,7 +116,9 @@ src_configure() {
 
 src_compile() {
        if use editor || use model-viewer; then
-               VIRTUALX_COMMAND="cmake-utils_src_compile" virtualmake
+               # work around parallel make issues - bug #561380
+               MAKEOPTS="-j1 ${MAKEOPTS}" \
+                       VIRTUALX_COMMAND="cmake-utils_src_compile" virtualmake
        else
                cmake-utils_src_compile
        fi