dev-ros/gazebo_plugins: Bump to 2.5.2.
authorAlexis Ballier <aballier@gentoo.org>
Sun, 28 Feb 2016 11:39:39 +0000 (12:39 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Sun, 28 Feb 2016 13:03:56 +0000 (14:03 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/gazebo_plugins/Manifest
dev-ros/gazebo_plugins/gazebo_plugins-2.5.2.ebuild [new file with mode: 0644]

index 29a123496cce965ca052bf448121965bb80c3909..f4649f44c43f09e2a448cbe978590075e77bd64a 100644 (file)
@@ -1 +1,2 @@
 DIST gazebo_ros_pkgs-2.5.1.tar.gz 1812295 SHA256 1d78839d174790db400466b4b165a79fea50177a3fbe59291539b8bdc1876d4e SHA512 2e0faaa770abe9ff2b41d176c7a3dadaf8749f32c924ba6018b3d7dabf0fe2a1e4ffd24c840c777229a4941e7f4522bf2287288619e2c819d4fb3c10fa431c9d WHIRLPOOL 09b0c5038b21a6cfc355fed8d8d2981cb845c8d209cb89112fb6daf1694b735dd68096ca7e2f255fdc2e8ba435080df186057344c81c2ac247c28d64019dbe32
+DIST gazebo_ros_pkgs-2.5.2.tar.gz 1815044 SHA256 849c541412b7312d3455827ccf386246b5bbc4d674e76ed0e9e08032026a929b SHA512 1f8b7034520712606e8389526115f0bae4084cbfdd1b5834f5c00233ae2864260cbb591512228f1519642fde860366a7b4f9602d5374817ca084494668b76bd4 WHIRLPOOL 13283cda29a4da4efb366d3074b9a55ca61b5c9e4a27b3cb467210405ed82334a849a3353f652bc6333e86e845f5845437ebaa23942a027a288fcd831fc77525
diff --git a/dev-ros/gazebo_plugins/gazebo_plugins-2.5.2.ebuild b/dev-ros/gazebo_plugins/gazebo_plugins-2.5.2.ebuild
new file mode 100644 (file)
index 0000000..2c0abf6
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Robot-independent Gazebo plugins for sensors, motors and dynamic reconfigurable components"
+LICENSE="BSD Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/roscpp
+       dev-ros/rospy
+       dev-ros/nodelet
+       dev-ros/angles
+       dev-ros/std_srvs
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/urdf
+       dev-ros/tf
+       dev-ros/tf2_ros
+       dev-ros/dynamic_reconfigure
+       dev-ros/driver_base
+       dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/pcl_conversions
+       dev-ros/image_transport
+       dev-ros/rosconsole
+       dev-ros/cv_bridge
+       dev-ros/polled_camera
+       dev-ros/diagnostic_updater
+       dev-ros/camera_info_manager
+       dev-ros/moveit_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-libs/libxml2
+       >=sci-electronics/gazebo-7:=
+       dev-games/ogre
+       sci-libs/pcl
+       dev-libs/boost:=
+       dev-qt/qtcore:4
+       dev-qt/qtgui:4
+       dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"