games-fps/rott: remove deprecated games eclass
authorAustin English <wizardedit@gentoo.org>
Thu, 9 Feb 2017 23:09:31 +0000 (17:09 -0600)
committerAustin English <wizardedit@gentoo.org>
Tue, 14 Feb 2017 23:41:18 +0000 (17:41 -0600)
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: Portage-2.3.2, Repoman-2.3.1

games-fps/rott/rott-1.1.2-r1.ebuild [new file with mode: 0644]

diff --git a/games-fps/rott/rott-1.1.2-r1.ebuild b/games-fps/rott/rott-1.1.2-r1.ebuild
new file mode 100644 (file)
index 0000000..d14d5f9
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Rise of the Triad for Linux!"
+HOMEPAGE="http://www.icculus.org/rott/"
+SRC_URI="http://www.icculus.org/rott/releases/${P}.tar.gz
+       demo? ( http://filesingularity.timedoctor.org/swdata.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="demo"
+
+RDEPEND="media-libs/libsdl[sound,joystick,video]
+       media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+       app-arch/unzip"
+
+S=${WORKDIR}/${P}/rott
+
+src_prepare() {
+       default
+
+       sed -i \
+               -e '/^CC =/d' \
+               Makefile || die "sed failed"
+       emake clean
+}
+
+src_compile() {
+       emake -j1 \
+               EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"/usr/share/${PN}/\\\"" \
+               SHAREWARE=$(usex demo "1" "0")
+}
+
+src_install() {
+       dobin rott
+       dodoc ../doc/*.txt ../README
+       doman ../doc/rott.6
+       if use demo ; then
+               cd "${WORKDIR}" || die
+               insinto /usr/share/${PN}
+               doins *.dmo huntbgin.* remote1.rts
+       fi
+}
+
+pkg_postinst() {
+       if ! use demo ; then
+               elog "To play the full version, just copy the"
+               elog "data files to /usr/share/${PN}/"
+       fi
+}