dev-python/billiard: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:51:27 +0000 (09:51 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:51:27 +0000 (09:51 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/billiard/Manifest
dev-python/billiard/billiard-3.3.0.23.ebuild [deleted file]
dev-python/billiard/billiard-3.5.0.0.ebuild [deleted file]

index 895432d8e627fdb90038845f1ec4141370bb3126..2a7f46aeb42c996f10750835031cd0e535ecc969 100644 (file)
@@ -1,4 +1,2 @@
-DIST billiard-3.3.0.23.tar.gz 151675 BLAKE2B 78cddee80df8a7d78f993ac33b40967c1f7f7b9c65fbb27d4038b48732a90e4dc016c83e009a5963e9cc208eaa6a5f74fd4a33f3faa0f49b2112f10c285be1f1 SHA512 2ab83512f5317230066f6f82615bda97c1fe6c0cf98281dc3ed486055584c6899695e6b9905d5825d657111c65c7f3552cf3fc7934ad2e4d4b3da09b538b09ca
-DIST billiard-3.5.0.0.tar.gz 155959 BLAKE2B dcfbcf7ca7d53cc1963d9753736e1001d2a4e1b19e4e67fb937619f327ec9c6af66ddf23a89ab4332499b16a6ede8bda86e82a8843a66d4d2b47d1c95885ee57 SHA512 c73adb0cd470e66cc6aaca848f24a991df3eda44e7adf0e83d2a7a1e87bba4381b165842e8cd297d43a4d01d4c006953107354b841cdad9fdde4e00e7a80c4f1
 DIST billiard-3.5.0.2.tar.gz 157299 BLAKE2B 1400d5a562dcab33c83a64cc7f7d14ad55b75677c3bb4c050cd4ba08a1f882e65d033653628fc3f2b52942081da3d5661fb0bcc5f2dd95f81a64749cd47d324f SHA512 581e1ac361324b36d79e280072952e490ef3470709b094f001c579feda54578c8e7b3e5afc93a5f878a6118c56afff7e59e13b3d3f2ccb2564b9b27cc810dae7
 DIST billiard-3.6.0.0.tar.gz 151342 BLAKE2B 46e29ae54144f3b4ebf3fbb4a5bdbba29662d3a6b292cbfef526618237103fd833d10eefe03211141264424590b33ddcd8722616d36ab4e2405198628cc29d5a SHA512 0a71de026d2a781b83fe2c549ecbfe9b6fbd574d8067fc46ba7eca6b76633a123620853d22696df3563d050043cfe75b14b4b69bf5217e0af964aaa0bcbe08ff
diff --git a/dev-python/billiard/billiard-3.3.0.23.ebuild b/dev-python/billiard/billiard-3.3.0.23.ebuild
deleted file mode 100644 (file)
index c7c7941..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_5 pypy pypy3 )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Python multiprocessing fork"
-HOMEPAGE="https://pypi.org/project/billiard/ https://github.com/celery/billiard"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               >=dev-python/unittest2-0.4.0[${PYTHON_USEDEP}]
-               >=dev-python/nose-1.3.4[${PYTHON_USEDEP}]
-               dev-python/nose-cover3[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy pypy3 )
-       )"
-# The usual req'd for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile() {
-       if !  python_is_python3; then
-               local CFLAGS=${CFLAGS}
-               append-cflags -fno-strict-aliasing
-       fi
-       distutils-r1_python_compile
-}
-
-python_compile_all() {
-       use doc && esetup.py build_sphinx --builder="html" --source-dir=Doc/
-}
-
-python_test() {
-       cd "${BUILD_DIR}" || die
-       # The teardown in __init__.py breaks pypy's installed nose
-       if [[ "${EPYTHON}" == pypy ]]; then
-               rm lib/billiard/tests/__init__.py || die
-               echo "from __future__ import absolute_import" >> ./lib/billiard/tests/__init__.py || die
-       fi
-       nosetests billiard.tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( build/sphinx/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/billiard/billiard-3.5.0.0.ebuild b/dev-python/billiard/billiard-3.5.0.0.ebuild
deleted file mode 100644 (file)
index 7da717f..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} pypy pypy3 )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Python multiprocessing fork"
-HOMEPAGE="https://pypi.org/project/billiard/ https://github.com/celery/billiard"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/case[${PYTHON_USEDEP}]
-               >=dev-python/unittest2-0.4.0[${PYTHON_USEDEP}]
-               >=dev-python/nose-1.3.4[${PYTHON_USEDEP}]
-               dev-python/nose-cover3[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy pypy3 )
-       )"
-# The usual req'd for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile() {
-       if !  python_is_python3; then
-               local CFLAGS=${CFLAGS}
-               append-cflags -fno-strict-aliasing
-       fi
-       distutils-r1_python_compile
-}
-
-python_compile_all() {
-       use doc && esetup.py build_sphinx --builder="html" --source-dir=Doc/
-}
-
-python_test() {
-       cd "${BUILD_DIR}" || die
-       # The teardown in __init__.py breaks pypy's installed nose
-       if [[ "${EPYTHON}" == pypy ]]; then
-               rm lib/billiard/tests/__init__.py || die
-               echo "from __future__ import absolute_import" >> ./lib/billiard/tests/__init__.py || die
-       fi
-       nosetests billiard.tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( build/sphinx/html/. )
-       distutils-r1_python_install_all
-}