dev-db/percona-server: disable more tests
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 4 May 2020 15:30:36 +0000 (17:30 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 4 May 2020 16:00:51 +0000 (18:00 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-db/percona-server/percona-server-8.0.19.10.ebuild

index ddd3e89b9beb7a396df4dbaca06586bef2e6db01..0eb015df2a820f630eb04f4bf0096ca4aa766ece 100644 (file)
@@ -405,12 +405,18 @@ src_test() {
        disabled_tests+=( "main.ssl_san;6808;False positive on IPv6-enabled hosts" )
        disabled_tests+=( "main.window_std_var;0;Known rounding error with latest AMD processors -- no upstream bug yet" )
        disabled_tests+=( "main.window_std_var_optimized;0;Known rounding error with latest AMD processors -- no upstream bug yet" )
+       disabled_tests+=( "main.with_recursive;6804;Known rounding error with latest AMD processors" )
        disabled_tests+=( "rpl_gtid.rpl_gtid_stm_drop_table;90612;Known test failure" )
        disabled_tests+=( "rpl_gtid.rpl_multi_source_mtr_includes;0;Know failure - no upstream bug yet" )
        disabled_tests+=( "sys_vars.myisam_data_pointer_size_func;87935;Test will fail on slow hardware" )
        disabled_tests+=( "x.message_compressed_payload;0;False positive caused by protobuff-3.11+" )
        disabled_tests+=( "x.message_protobuf_nested;6803;False positive caused by protobuff-3.11+" )
 
+       if ! hash zip 1>/dev/null 2>&1 ; then
+               # no need to force dep app-arch/zip for one test
+               disabled_tests+=( "innodb.partition_upgrade_create;0;Requires app-arch/zip" )
+       fi
+
        local test_ds
        for test_infos_str in "${disabled_tests[@]}" ; do
                IFS=';' read -r -a test_infos_arr <<< "${test_infos_str}"