dev-java/netbeans-enterprise: fixed eapi 6 issue
authorMiroslav Šulc <fordfrog@gentoo.org>
Thu, 6 Oct 2016 09:08:54 +0000 (11:08 +0200)
committerMiroslav Šulc <fordfrog@gentoo.org>
Thu, 6 Oct 2016 09:08:54 +0000 (11:08 +0200)
Package-Manager: portage-2.3.1

dev-java/netbeans-enterprise/netbeans-enterprise-8.2.ebuild

index 1990ecfd81a97b2688f664c4c35c32011c95a657..5af83e35d0a82af6c77554a537b841f61e922587 100644 (file)
@@ -140,19 +140,6 @@ src_prepare() {
 
        epatch netbeans-8.2-build.xml.patch
 
-       # Support for custom patches
-       if [ -n "${NETBEANS9999_PATCHES_DIR}" -a -d "${NETBEANS9999_PATCHES_DIR}" ] ; then
-               local files=`find "${NETBEANS9999_PATCHES_DIR}" -type f`
-
-               if [ -n "${files}" ] ; then
-                       einfo "Applying custom patches:"
-
-                       for file in ${files} ; do
-                               epatch "${file}"
-                       done
-               fi
-       fi
-
        einfo "Symlinking external libraries..."
        java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
        java-pkg_jar-from --into j2eeapis/external glassfish-deployment-api-1.2 glassfish-deployment-api.jar jsr88javax.jar
@@ -202,6 +189,7 @@ src_prepare() {
        popd >/dev/null || die
 
        java-pkg-2_src_prepare
+       default
 }
 
 src_install() {