dev-python/pylint: Remove old
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 13:30:23 +0000 (14:30 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 13:58:46 +0000 (14:58 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pylint/Manifest
dev-python/pylint/pylint-1.6.5-r1.ebuild [deleted file]

index 04d74c4469b73c708a0533a537e7034e06b14808..8d95771f99568b81cda3df8713c9ba345b28b5cb 100644 (file)
@@ -1,3 +1,2 @@
-DIST pylint-1.6.5.tar.gz 465578 BLAKE2B 05412a528878633ef7529dd2f2d2d1989bc9406666626d62764f476bbc024e34fea06883fae829fe6617ebfffde54dfa5600c140b9a25e6c9633f48d76f5c331 SHA512 2fac352dc752b37f1ce4f7fefe5afbbc880d7e6c38f164d1c50734716af1dd6fe31f7d41e145a8256837d5a63b1989efec40c169fc14840cf8eb4e18d9bb2410
 DIST pylint-2.3.1.tar.gz 577767 BLAKE2B 2af206a9d9be04f369c2bbc39c5ddb80c29a5a39c20d75bfec84498882eab628a7cf5abcc5786933304ed99bd00ffa142b9a58abab348c947799f962b877bb30 SHA512 924d8adc95f04ba750b3b44fe79ac569151ea7c8f693cc9867bcda3878209ebc2202931702b98f80709d161d3781b6e181aea0ded35a3323c023497e2a749ea9
 DIST pylint-2.4.4.tar.gz 646113 BLAKE2B d62b66b056e01cc13e90f45ff4a11f94983e0b9b42b9a05e5c7b7385280000d15ead9a282e7eea31a8ee6a24ffe539576a6e9bd40dc4d89093263da99029123b SHA512 835e0687ebc76c530e0042c5a5188b8aedab446531f621627e990cbeb37ab6ecc8de0f8c6ab171abaa63488e049e8d7782958461421f9a4127435f56b6d2ed0b
diff --git a/dev-python/pylint/pylint-1.6.5-r1.ebuild b/dev-python/pylint/pylint-1.6.5-r1.ebuild
deleted file mode 100644 (file)
index 6a23b2b..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="https://www.logilab.org/project/pylint
-       https://pypi.org/project/pylint/
-       https://github.com/pycqa/pylint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ia64 ppc ppc64 sparc x86"
-IUSE="doc examples test"
-
-RDEPEND="
-       >=dev-python/astroid-1.4.5[${PYTHON_USEDEP}]
-       <dev-python/astroid-1.5.0[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
-       dev-python/mccabe
-       $(python_gen_cond_dep '
-               dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]
-               dev-python/configparser[${PYTHON_USEDEP}]' python2_7)"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( ${RDEPEND} )"
-
-RESTRICT="test" # multiple failures
-
-# Usual. Requ'd for impl specific failures in test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
-       # selection of straight html triggers a trivial annoying bug, we skirt it
-       use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml
-}
-
-python_test() {
-       ${EPYTHON} \
-               -m unittest discover \
-               -s pylint/test/ -p "*test_*".py \
-               --verbose || die
-}
-
-python_install_all() {
-       doman man/{pylint,pyreverse}.1
-       if use examples ; then
-               docinto examples
-               dodoc -r examples/.
-       fi
-       use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
-       distutils-r1_python_install_all
-}
-
-pkg_postinst() {
-       # Optional dependency on "tk" USE flag would break support for Jython.
-       optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." dev-lang/python[tk]
-}