media-fonts/noto-emoji: Commit forgotten patch
authorPacho Ramos <pacho@gentoo.org>
Sun, 2 Jun 2019 14:49:30 +0000 (16:49 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sun, 2 Jun 2019 14:51:15 +0000 (16:51 +0200)
Closes: https://bugs.gentoo.org/687204
Package-Manager: Portage-2.3.67, Repoman-2.3.13
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
media-fonts/noto-emoji/files/noto-emoji-20190328-use-gm.patch [new file with mode: 0644]

diff --git a/media-fonts/noto-emoji/files/noto-emoji-20190328-use-gm.patch b/media-fonts/noto-emoji/files/noto-emoji-20190328-use-gm.patch
new file mode 100644 (file)
index 0000000..6b51d0f
--- /dev/null
@@ -0,0 +1,27 @@
+--- a/Makefile~        2019-03-28 17:45:53.000000000 +0100
++++ b/Makefile 2019-06-02 10:36:55.587055453 +0200
+@@ -21,7 +21,7 @@
+ PNGQUANT = pngquant
+ PNGQUANTFLAGS = --speed 1 --skip-if-larger --quality 85-95 --force
+ BODY_DIMENSIONS = 136x128
+-IMOPS := -size $(BODY_DIMENSIONS) canvas:none -compose copy -gravity center
++IMOPS = -size 136x128 -background none -gravity center -extent 136x128 -compose copy
+ # zopflipng is better (about 5-10%) but much slower.  it will be used if
+ # present.  pass ZOPFLIPNG= as an arg to make to use optipng instead.
+@@ -165,13 +165,13 @@
+ # imagemagick packaged with ubuntu trusty (6.7.7-10) by using -composite.
+ $(EMOJI_DIR)/%.png: $(EMOJI_SRC_DIR)/%.png | $(EMOJI_DIR)
+-      @convert $(IMOPS) "$<" -composite "PNG32:$@"
++      @gm convert $(IMOPS) "$<" "PNG32:$@"
+ $(FLAGS_DIR)/%.png: $(FLAGS_SRC_DIR)/%.png ./waveflag | $(FLAGS_DIR)
+       @./waveflag $(FLAGS_DIR)/ "$<"
+ $(RESIZED_FLAGS_DIR)/%.png: $(FLAGS_DIR)/%.png | $(RESIZED_FLAGS_DIR)
+-      @convert $(IMOPS) "$<" -composite "PNG32:$@"
++      @gm convert $(IMOPS) "$<" "PNG32:$@"
+ flag-symlinks: $(RESIZED_FLAG_FILES) | $(RENAMED_FLAGS_DIR)
+       @$(subst ^, ,                                  \