media-video/vcsi: enable python3.8, EAPI-7
authorJoonas Niilola <juippis@gentoo.org>
Tue, 28 Apr 2020 13:50:53 +0000 (16:50 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 28 Apr 2020 13:51:42 +0000 (16:51 +0300)
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
media-video/vcsi/vcsi-7-r1.ebuild [new file with mode: 0644]

diff --git a/media-video/vcsi/vcsi-7-r1.ebuild b/media-video/vcsi/vcsi-7-r1.ebuild
new file mode 100644 (file)
index 0000000..d659df0
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Create thumbnail sheets from video files"
+HOMEPAGE="https://github.com/amietn/vcsi"
+SRC_URI="https://github.com/amietn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]
+       dev-python/numpy[${PYTHON_USEDEP}]
+       dev-python/parsedatetime[${PYTHON_USEDEP}]
+       dev-python/pillow[${PYTHON_USEDEP}]
+       dev-python/texttable[${PYTHON_USEDEP}]
+       media-fonts/dejavu
+       media-video/ffmpeg"
+
+distutils_enable_tests nose