dev-python/cached-property: Remove test compat with removed impls
authorMichał Górny <mgorny@gentoo.org>
Mon, 2 Mar 2020 05:21:32 +0000 (06:21 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 2 Mar 2020 05:42:35 +0000 (06:42 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/cached-property/cached-property-1.5.1.ebuild

index 879fa766f1b00e24f221fe61c1eb8cfda4d9d196..88b62f7a15e8e9cf499873d75f65ecb99eaf4e16 100644 (file)
@@ -13,28 +13,16 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="amd64 ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
-DEPEND="test? (
-               dev-python/pytest
-               dev-python/freezegun
-               )"
+DEPEND="
+       test? (
+               dev-python/freezegun[${PYTHON_USEDEP}]
+       )"
 RDEPEND=""
 
+distutils_enable_tests pytest
+
 src_install() {
        distutils-r1_src_install
        dodoc README.rst HISTORY.rst CONTRIBUTING.rst AUTHORS.rst
 }
-
-python_test() {
-       local ignore=""
-       if [[ ${EPYTHON} == python2.7 ]]; then
-               ignore="--ignore=tests/test_coroutine_cached_property.py \
-                       --ignore=tests/test_async_cached_property.py"
-       fi
-       if [[ ${EPYTHON} == python3.4 ]]; then
-               ignore="--ignore=test_async_cached_property.py"
-       fi
-       py.test -v ${ignore} tests/ || die
-}