app-admin/graylog2: bump to 2.5.1
authorTomas Mozes <hydrapolic@gmail.com>
Mon, 7 Jan 2019 11:33:05 +0000 (12:33 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 19 Jan 2019 01:54:33 +0000 (02:54 +0100)
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/10762
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
app-admin/graylog2/Manifest
app-admin/graylog2/graylog2-2.5.1.ebuild [new file with mode: 0644]

index d869968db913f570c22a6771d0208e966e888456..4508ce61759ec88bed436dfc1b8ae86b66225480 100644 (file)
@@ -1 +1,2 @@
 DIST graylog-2.4.6.tgz 122985232 BLAKE2B 3a409a08f27c3abf1eadca57c4e8c9afc334655e050c0db9bad9d16e03acab6d92bfced708486ad8383987842d9b0a5ddc54e28d29fc426761fcb0ab8c65844c SHA512 e1941f4740f43c5b92b5faa7cde06fb15294acfed5f0f56cb21a7ceffb8616382b68b67d049a2982c68833d706e57b77f365665f12193d053a2ac0996801bcbe
+DIST graylog-2.5.1.tgz 123878927 BLAKE2B d168579be4d20e3a8081d608247e7101fc5d99ddd2b5f063f94d7e91d4095c6bd016a4bc1be0f0e08b5043b771070312286404ece5eacc51e4a8730dfc13dab1 SHA512 44e2ca00e47a34708cea94b74fdc0f56f3a381f161d25633bdf7685fbcd989937163508f8b47b0869c7daacec6c8bd2c874f9381e196ffb3194eb6e3f96b3ce9
diff --git a/app-admin/graylog2/graylog2-2.5.1.ebuild b/app-admin/graylog2/graylog2-2.5.1.ebuild
new file mode 100644 (file)
index 0000000..b4ba9c0
--- /dev/null
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit user
+
+DESCRIPTION="Free and open source log management"
+HOMEPAGE="https://graylog.org"
+SRC_URI="https://packages.graylog2.org/releases/graylog/graylog-${PV}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="strip"
+
+RDEPEND="virtual/jdk:1.8"
+
+DOCS=(
+       COPYING README.markdown UPGRADING.rst
+)
+
+GRAYLOG_DATA_DIR="/var/lib/graylog2"
+GRAYLOG_INSTALL_DIR="/usr/share/graylog2"
+QA_PREBUILT="${GRAYLOG_INSTALL_DIR}/lib/sigar/libsigar*"
+
+S="${WORKDIR}/graylog-${PV}"
+
+pkg_setup() {
+       enewgroup graylog
+       enewuser graylog -1 -1 -1 graylog
+}
+
+src_prepare() {
+       default
+
+       # Stick to architecture of build host
+       if ! use amd64; then
+               rm -r lib/sigar/libsigar-amd64-*.so || die "Failed in removing AMD64 support libraries"
+       fi
+       if ! use ppc64; then
+               rm -r lib/sigar/libsigar-ppc64-*.so || die "Failed in removing PPC64 support libraries"
+       fi
+       if ! use x86; then
+               rm -r lib/sigar/libsigar-x86-*.so || die "Failed in removing X86 support libraries"
+       fi
+       # Currently unsupported platforms
+       # QA warning galore but testing/patches welcome
+       rm lib/sigar/libsigar-*freebsd*so \
+               lib/sigar/libsigar-*solaris*so \
+               lib/sigar/libsigar-*hpux*.sl \
+               lib/sigar/libsigar-*macosx*.dylib \
+               lib/sigar/libsigar-ia64-*.so \
+               lib/sigar/libsigar-ppc-*.so \
+               lib/sigar/libsigar-s390x*.so \
+               lib/sigar/*winnt* || die "Failed in removing unsupported platform libraries"
+
+       # gentoo specific paths
+       sed -i "s@\(node_id_file = \).*@\1${GRAYLOG_DATA_DIR}/node-id@g; \
+               s@\(message_journal_dir = \).*@\1${GRAYLOG_DATA_DIR}/data/journal@g; \
+               s@#\(content_packs_dir = \).*@\1${GRAYLOG_DATA_DIR}/data/contentpacks@g" \
+               graylog.conf.example || die
+}
+
+src_install() {
+       default
+
+       insinto /etc/graylog2
+       doins graylog.conf.example
+
+       insinto "${GRAYLOG_DATA_DIR}/data/contentpacks"
+       doins data/contentpacks/grok-patterns.json
+
+       insinto "${GRAYLOG_INSTALL_DIR}"
+       doins graylog.jar
+       doins -r lib plugin
+
+       newconfd "${FILESDIR}/confd-r2" graylog2
+       newinitd "${FILESDIR}/initd-r2" graylog2
+}
+
+pkg_postinst() {
+       ewarn "Graylog does not depend on need.net any more (#439092)."
+       ewarn
+       ewarn "Please configure rc_need according to your binding address in:"
+       ewarn "/etc/conf.d/graylog2"
+}