dev-libs/atk: Version bump to 2.36.0
authorMatt Turner <mattst88@gentoo.org>
Sun, 26 Apr 2020 01:31:06 +0000 (18:31 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sun, 26 Apr 2020 01:53:57 +0000 (18:53 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-libs/atk/Manifest
dev-libs/atk/atk-2.36.0.ebuild [new file with mode: 0644]

index e59c9013691671ec9b2b19082280ee5b5266d605..e85cc48a15670c213020500902b7d966af467d5f 100644 (file)
@@ -1,3 +1,4 @@
 DIST atk-2.32.0.tar.xz 292088 BLAKE2B 15f093db60cc54d1a5a18dc78cb9d64fa73e18dadb724fe5143956199f4ff1aa4ea9daf0796b14f228a1d91f1d44e88749c67fe5a6a84bd001916d78be4680f9 SHA512 8cd2a3ee006f21835f3e564f2e1de4ae61bd9529b4c0b4f2e3ece88e905e2dd36b67affb089f41582806a1397576602a526a4b8698303708894f20af97ecac22
 DIST atk-2.34.1.tar.xz 293140 BLAKE2B 8ae280583867460734ca001eb01963eefcc519eb09658e2e793cd1a07831e8e5ade20a4d38bb5925a1103da206d9d6283a2b1892c671f12090b3eefac04b34e1 SHA512 a7c8ec7c2166bb8734b065402bf7700cdc69f56c0958663e88596b155a20063e4cfbf1754d8b8ed94a4e509db2e97e2603b0a8037e61028acc85930e631a633e
 DIST atk-2.35.1.tar.xz 294224 BLAKE2B e2e4d5768d8add243bb064e3ec43bd4665bf16f0211be721788a3a3bb96a93e402671e0bf5c7e2a1747ac673fee0b5022cb1798481a5ff0b1cc61f41dc0c8279 SHA512 da81cb4a6a5f2d8d83fa8a430b181b009e5407d906bb000a2d86481e7fea9fa6fb6e9dcd6790d4efdf513e5fe8fcb32ac3ec49d4ce3c76010145b8baacf2ae1b
+DIST atk-2.36.0.tar.xz 299100 BLAKE2B 46f0cc10052788643c09e27e36a3f74439864cf5c8fdfcf5850e3e7df596ac8a2a3dd8a01856503d43995ff1cc36ec0ca63884133f2c5f4a3634aad2c5119997 SHA512 d0f18204eaf96511e8448e3dfbc4b6953a7cf8b816151fb7caf5592cf578572b1cdb16836fe2157b11e3ad018ef171f1ca1bfdf255bb31bb455716d7519fd634
diff --git a/dev-libs/atk/atk-2.36.0.ebuild b/dev-libs/atk/atk-2.36.0.ebuild
new file mode 100644 (file)
index 0000000..4e54ebb
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson multilib-minimal xdg
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="gtk-doc +introspection"
+
+RDEPEND="
+       >=dev-libs/glib-2.38.0:2[${MULTILIB_USEDEP}]
+       introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-util/glib-utils
+       gtk-doc? (
+               >=dev-util/gtk-doc-1.25
+               app-text/docbook-xml-dtd:4.3 )
+       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+       >=sys-devel/gettext-0.19.8
+"
+
+multilib_src_configure() {
+       local emesonargs=(
+               -Ddocs=$(multilib_native_usex gtk-doc true false)
+               -Dintrospection=$(multilib_native_usex introspection true false)
+       )
+       meson_src_configure
+}
+
+multilib_src_compile() {
+       meson_src_compile
+}
+
+multilib_src_test() {
+       meson_src_test
+}
+
+multilib_src_install() {
+       meson_src_install
+}