dev-libs/gdl: bump to 3.28.0
authorMart Raudsepp <leio@gentoo.org>
Fri, 3 Aug 2018 09:59:52 +0000 (12:59 +0300)
committerMart Raudsepp <leio@gentoo.org>
Fri, 3 Aug 2018 10:06:35 +0000 (13:06 +0300)
This bump has translation updates and a runtime warning fix, safe
with GNOME 3.24.
Also fixes compat with newer python-based gtk-doc, but we don't
expose a gtk-doc regeneration option in our ebuild. While here,
be explicit about that fact with a --disable-gtk-doc argument.

Package-Manager: Portage-2.3.43, Repoman-2.3.10

dev-libs/gdl/Manifest
dev-libs/gdl/gdl-3.28.0.ebuild [new file with mode: 0644]

index 06002a474b40d46a581a25ccd9d51f876ffc46dc..f1310f7d8257e4f78209ffc459c3e63e1111d808 100644 (file)
@@ -1 +1,2 @@
 DIST gdl-3.22.0.tar.xz 529072 BLAKE2B 7215c53051dc3ec467c97615fa7e8059bf6c610cd166bea28ba256bf26b4de75fc63ab1e627acdeb8228257844ae1b47bb5d88cef24c7efcbd5bfbe508928eae SHA512 408fd75627497c658b65e9cd39b8779ad0db2fdc1f780e369237fbdd3f0ccc035cd86456ff72e1581c524f1d35673d3b31ebb074290babf025596d08d823833d
+DIST gdl-3.28.0.tar.xz 541252 BLAKE2B 7254a9e15e9e79229c85b12c02ff5307bf99569428b13629ac8b3a5e79383f14a248d6e74f139e44145cd1a2825a2d10859c922a07a22fe1243edfafdb01514b SHA512 d6a697b8cd098abfcb560d8b6c8a326b05f6f22211a3bc92ea458d643170abc514acd4105e372fb61777d2a5dd09709d7e3d6d3ad75215fffdf2809b3df3c471
diff --git a/dev-libs/gdl/gdl-3.28.0.ebuild b/dev-libs/gdl/gdl-3.28.0.ebuild
new file mode 100644 (file)
index 0000000..aa4f620
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="GNOME docking library"
+HOMEPAGE="https://git.gnome.org/browse/gdl"
+
+LICENSE="LGPL-2.1+"
+SLOT="3/5" # subslot = libgdl-3 soname version
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+       dev-libs/glib:2
+       >=x11-libs/gtk+-3.0.0:3[introspection?]
+       >=dev-libs/libxml2-2.4:2
+       introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+       >=dev-util/gtk-doc-am-1.4
+       >=dev-util/intltool-0.40.4
+       virtual/pkgconfig
+"
+
+src_configure() {
+       gnome2_src_configure \
+               $(use_enable introspection) \
+               --disable-gtk-doc
+}