dev-util/buildbot-console-view: Version bump to 1.3.0
authorBrian Dolbec dolsen <dolsen@gentoo.org>
Thu, 26 Jul 2018 17:01:59 +0000 (10:01 -0700)
committerBrian Dolbec dolsen <dolsen@gentoo.org>
Thu, 26 Jul 2018 17:17:10 +0000 (10:17 -0700)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-util/buildbot-console-view/Manifest
dev-util/buildbot-console-view/buildbot-console-view-1.3.0.ebuild [new file with mode: 0644]

index 133e48b396890fe8118bc5f9eb1713ccac2395a8..ac0799e71c2c91bb7da502cfe4b16f32191f0783 100644 (file)
@@ -1,2 +1,3 @@
 DIST buildbot-console-view-0.9.12.tar.gz 640923 BLAKE2B cc0da84395aca571803e73260d826633553ed10ede6d66d112dfa8bcdc4f1bd376695ee0ee4a715f1fa3705329033044d9358731c0b807c54b40b4e32a04f565 SHA512 4a73994c29fe1f78c4432bdb42fe14106b8d7887bb35f2835b203f4818844d3e8d2ea308fc4fb2bd562de302bd7cf6612fe047476512feac068eca3891a49522
 DIST buildbot-console-view-1.1.2.tar.gz 640509 BLAKE2B 481b8049e606d47be8b171c24a210d6c95ce13ee4a4d46fd689ee836857e8d054f1799ce53de3931f820f02061cdd0c4a47686cd1724fe1c39ab33ca0f274d76 SHA512 23a14d3264802b2cf9a6a7cab0592c6391dc55a8805c17529c3279b129aaab1df97999ffd5fdc0927e7d5fb204e4114b4672018102381523599310cf7223950f
+DIST buildbot-console-view-1.3.0.tar.gz 640506 BLAKE2B bf68136edbe734514b662a580b9025626b6e0acd48f49ccee979c38d1a2eac13e8fd13bf4c9f62948694ed003de3ee6c44a9d734561a1b5ed4e1d9d330b39f3f SHA512 5b4fa27c8cca57df083c3044729bc6086086dabe819e215b02fe4fda0863b62658925433bbc90d9b38f4309af50b2312b3c9aaefff96a1f62b18d160ca66f205
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-1.3.0.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-1.3.0.ebuild
new file mode 100644 (file)
index 0000000..23b0c0a
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="Buildbot console-view plugin"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-console-view/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+       KEYWORDS=""
+else
+       KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND="
+       ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+       dev-python/mock[${PYTHON_USEDEP}]
+       ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+       >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+       distutils_install_for_testing
+
+       esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+}